Jump to content
OMRON Forums

Root Access PowerPMAC PowerPC EP460C CPU


Recommended Posts



I am in a bit of a predicament i suppose.

I bought second hand this PowerPMAC cpu in the hope I could upgrade my Turbo2 Umac system with it.

I tested the board and it seems to work.

I used the PowerPmacIP folder "trick" to get the IP address and this was the default

I was NOT able to log in via the PowerPMAC IDE4, it gives connection failing. 

Now, I did read a big part of the forum entries here, but not all of them.

I can see through the boot.log that the board is actually booting and seems to work.

What I do think is happening is that the board is not on the default deltatau root password.

now, because I cannot contact a previous owner that actually used the board, I was wondering If there is a way to restore the

default root account/password.

I totally do not care if I have to wipe to board and re-install the firmware. Problem is that the IDE need to connect first to do that

and that I do not have a suitable image of course.

I know that I could also use a USB-key to restore the firmware, but going back to the fact I do not have the firmware.......

I am not an professional user of the Delta Tau universe, I build my own CNC controlled by a turbo2 Umac system with lineair

Brushless axes. This works very nice. Just the fact now that I want to upgrade to PowerPMAC because I want to use Win11 is causing some problems.


Are there any tips/hints/ solutions maybe?


Best regards, Otto



s-l1600 (2).jpg


s-l1600 (1).jpg


interfaces boot.log

Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Can PPMAC be detected through the ping command?
Can you log in to PPMAC through Putty?

Please ensure that the computer IP address and PPMAC are in the same network segment.

Link to comment
Share on other sites

Hello, sorry for being late, was away from home.

Yes, as you can see from the included interfaces.txt I am able to ping the card and geta response.

further more,I AM ableto Putty into the card and get root access there, password is the standard deltatau password.

I have to say that I removed the old leaking backup cattery and replaced it with a new one after cleaning, No damage to pcb.

I have included a print screen from my Putty access.

I had still no access to the card using PowerPmac IDE4 so than i disabled the firewall and checked again=>not working.

I am running Win 11 as can be seen in the screen dump.

What I wilkl try to do is re-installing IDE 4 and see what that does.


regards, Otto


root access granted.jpg



Link to comment
Share on other sites

Can I use Putty to log in and use the gpascii command to access PPMAC?

What is your firmware version?

After using the gpascii command, you can use the vers command to query the firmware version.

Link to comment
Share on other sites

Posted (edited)

I did the following,

I installed the IDE 4 on a Windows 10 laptop, did not solve the problem, no communication via the IDE.

I again used Putty to get more information and I can NOT get gpascii to work (see image)

What happens is that after I give the command, nothing happens, no response anymore from ppmac until I use CTRL-C to abort.

What I was able to do is use the IDE4 through the USB connection to the maintenance port of the EP460C ppmac and made an backup image. This wrote an *.vhd file to my selected location. Further I got an E:-drive which was accessable on my laptop.

What I did see on my laptop was when I was browsing through the folders on this drive, that I have data corruption on the usrflash folder. When I look into it, there is a lot of garbage shown with a total size of >78Gb (yes Gigabyte)

I could not erase the contents of this folder because it says that it is a read-only file system.

It seems that even when you do a factory reset through the folder on a SD-card, the usrflash is not restored?  How can I re-initialize the flash to a default setting?

I did use the PowerPmacConfigLoad with a usrflash with a project in it which I got from an un-corrupted usrflash.1 folder but this did not work.

Could I have a broken flash chip maybe?

I think I get now closer to the source of my problem but not yet to the solution of it.


regards, Otto

fail gpascii.jpg


Edited by Hersoft
Link to comment
Share on other sites

  • 2 weeks later...



So to give an update on my problemematic EP460EX cpu...


After some deep soul searching and did yhe following things:

I reconnected the USB cable to have access to the "dos" part of the file system.

Because I already tried and failed to delete the USRFLASH folder, which contained the garbled files, I ran a dos error checking on the disk and it found problems and corrected them. When finished I had an extra folder on the disk named FOUND.000 cantaining 467 recoverd file fragments.

than I copied the contents from USRFLASH.3 to USRFLASH and powered off.

I removed the USB-cable and powered on again.

After confirming I could ping, I puttied in (lol) and was able to get into ppmac by GPASCII-2


I started PMAC IDE and he presto=>working Power Pmac.

I was able to build and download one of the examples (Program Development)

I could see my 2 option boards and it kept showing the response counter.

No errors during build and download.


Regards, all for the comments. Much apreciated.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...