Jump to content
OMRON Forums

Installing a Newer Version of Python


Recommended Posts

The installed Linux footprint is limited to the versions acquired at the time of that Power PMAC FW release. Note that some Linux components not required by PMAC FW have been removed as in the Linux “man-pages “to allow for greater available user disk space. Keep in mind that other installed applications not required by PMAC FW may be removed in future versions.


Having said that you can install Linux packages such as updated versions of “Python”. These are very well documented on the internet. I would recommend making an image of your PMAC in case anything does not go well.

Link to comment
Share on other sites

  • 4 months later...
I tried to install a newer version of python on one of our controllers.
I got a python 3.7 package from:
and tried to use the IDE option "PowerPAMC -> Install Package" to install it but I am getting the following error:
 python3.7-minimal pre-depends on libc6 (>= 2.28)
  libc6:armhf is installed, but is version 2.19-18+deb8u7
when I try to change the version of libc6  I'm getting this error:
dpkg: error processing archive /var/ftp/usrflash/libc6_2.36-9+deb12u4_armhf.deb (--install):
 installing libc6:armhf would break openssh-server, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Is there a plan to move to a newer version of Debian and newer python?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...