Jump to content
OMRON Forums

Background C program refuses to start


Recommended Posts

My issue is as follows:
I have written a background C application...tested it with an SSH terminal session (so I can easily view printf output)
'Works fine...  I build and download the entire project and add a watch window with some variables that the C prog has access to, so I can see the application is running.   I can now start the application from the task manager...and see the variables update, so I know the program has started.  I can also stop via the task manager...and the program stops.

But, I cannot seem to start the program from a plc or online command.

I've tried the example from the manual:

  system "/var/ftp/usrflash/Project/C\ Language/Background\ Programs/mycapp.out";

I've tried this, too:

  p1 = sprintf(256, "/var/ftp/usrflash/Project/C Language/Background Programs/mycapp.out" )
  system "%s", 256


Neither causes the program to start.  

Any ideas on what's going on?   ... or any debugging techniques that would be useful in this case ??


I’m using:
IDE ver:
firmware ver: (CK3M)


Thanks in advance!


Edited by DaveBarnett
Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

This has been resolved. Both of the following work OK in a PLC:


system "/var/ftp/usrflash/Project/C\ Language/Background\ Programs/mycapp.out"


p1 = sprintf(256, "/var/ftp/usrflash/Project/C\ Language/Background\ Programs/mycapp.out")

system "%s", 256

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...