Jump to content
OMRON Forums

IDE won't connect


Guest DavisG
 Share

Recommended Posts

Guest DavisG
Ok - kind of a weird one. Symptom - IDE will not connect, asks you to check password, but you can connect with telnet from a command prompt Clue - takes > 10 seconds to ask for password after typing the telnet command in command prompt Cause - The IDE is timing out waiting on the return from the telnet request. Root issue in this case was that the ETH1 device was set up in the /opt/etc/network/interfaces file but nothing was plugged in Fix - From telnet: mount -o remount,rw /opt #makes /opt read write edit the /opt/etc/network/interfaces file with vi to comment out the unused network save and exit copy the edited file to the /.readonly/etc/network directory mount -o remount,ro /opt #don't forget to make /opt read only Also, Atul is going to add a parameter in the IDE for the timeout. If you are having the same problem for other reasons (maybe connecting across a really slow corporate network) you can do a short term (does not last past a reboot) by: mount -o remount,rw / echo 192.168.1.234 >> /.readonly/etc/hosts echo 192.168.1.234 >> /etc/hosts mount -o remount,ro / from the telnet session - use your pc IP address where I have 192.168.1.234
Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

In the service pack for July release we added registry entry to set this timeout and also we give error in the Delta tau log window in the IDE(View-Output and select Delta Tau Log) and pointing towards this registry to set new value which will be used in the next session of IDE. Service Pack is not released yet but it is under test. -atul [quote='DavisG' pid='633' dateline='1282044540'] Ok - kind of a weird one. Symptom - IDE will not connect, asks you to check password, but you can connect with telnet from a command prompt Clue - takes > 10 seconds to ask for password after typing the telnet command in command prompt Cause - The IDE is timing out waiting on the return from the telnet request. Root issue in this case was that the ETH1 device was set up in the /opt/etc/network/interfaces file but nothing was plugged in Fix - From telnet: mount -o remount,rw /opt #makes /opt read write edit the /opt/etc/network/interfaces file with vi to comment out the unused network save and exit copy the edited file to the /.readonly/etc/network directory mount -o remount,ro /opt #don't forget to make /opt read only Also, Atul is going to add a parameter in the IDE for the timeout. If you are having the same problem for other reasons (maybe connecting across a really slow corporate network) you can do a short term (does not last past a reboot) by: mount -o remount,rw / echo 192.168.1.234 >> /.readonly/etc/hosts echo 192.168.1.234 >> /etc/hosts mount -o remount,ro / from the telnet session - use your pc IP address where I have 192.168.1.234 [/quote]
Link to comment
Share on other sites

  • 5 months later...
[quote='agovande' pid='637' dateline='1282146835'] In the service pack for July release we added registry entry to set this timeout and also we give error in the Delta tau log window in the IDE(View-Output and select Delta Tau Log) and pointing towards this registry to set new value which will be used in the next session of IDE. Service Pack is not released yet but it is under test. -atul [quote='DavisG' pid='633' dateline='1282044540'] Ok - kind of a weird one. Symptom - IDE will not connect, asks you to check password, but you can connect with telnet from a command prompt Clue - takes > 10 seconds to ask for password after typing the telnet command in command prompt Cause - The IDE is timing out waiting on the return from the telnet request. Root issue in this case was that the ETH1 device was set up in the /opt/etc/network/interfaces file but nothing was plugged in Fix - From telnet: mount -o remount,rw /opt #makes /opt read write edit the /opt/etc/network/interfaces file with vi to comment out the unused network save and exit copy the edited file to the /.readonly/etc/network directory mount -o remount,ro /opt #don't forget to make /opt read only Also, Atul is going to add a parameter in the IDE for the timeout. If you are having the same problem for other reasons (maybe connecting across a really slow corporate network) you can do a short term (does not last past a reboot) by: mount -o remount,rw / echo 192.168.1.234 >> /.readonly/etc/hosts echo 192.168.1.234 >> /etc/hosts mount -o remount,ro / from the telnet session - use your pc IP address where I have 192.168.1.234 [/quote] [/quote] Another way to resolve connection issue.... In the service pack2 of IDE release we have added the registry entry. This will be used to set the timeout for telnet connection. User will need to change the default timeout if ... 1.Uses Video Option with PowerPMAC and Telent Protocol. 2.Overloaded PowerPMAC Task (>80%) which will result in less time for host communication. The registry entry path:HKEY_LOCAL_MACHINE\SOFTWARE\Delta Tau Data Systems Inc\Global Settings\ProtocolTimeout User can set the Time out value to this registry to resolve connection timeouts. Thanks, Atul
Link to comment
Share on other sites

The registry entry path:HKEY_LOCAL_MACHINE\SOFTWARE\Delta Tau Data Systems Inc\Global Settings\ProtocolTimeout For 64 bit Win7 it is found at: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Delta Tau Data Systems Inc\Global Settings\ProtocolTimeout
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...