Jump to content
OMRON Forums

[SOLVED] Accessing macro slave variables above i1000


KEJR
 Share

Recommended Posts

Hello, I am new to Macro, so please excuse my terminology. I need to set a parameter on a macro servo drive, which, from what I understand is done with MacroSlave0,i1024 type commands. It seems that anything above i999 gives me an error on the terminal of: MacroSlave0,i1000 stdin:28:1: error #21: ILLEGAL PARAMETER: MacroSlave0,i1000 So is this an error of the command processor, or are these parameters not accessable? Our variables on our drives start at i1024. Also, am I able to access these from C calls? the routine I'm using is programmed in C so I could use this as a workaround if it is possible. Is there an example of this available? Thanks, KEJR
Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

[quote='KEJR' pid='1318' dateline='1297286726'] I need to set a parameter on a macro servo drive, which, from what I understand is done with MacroSlave0,i1024 type commands. It seems that anything above i999 gives me an error[/quote] KEJR - what firmware and IDE rev are you using? In the past I have used IDEs/firmwares ranging from the July release on up with MACRO. I am not seeing the problem with MACRO i vars with any of these releases. We have used the Command() function to get/set variables across MACRO. Davis
Link to comment
Share on other sites

[quote='DavisG' pid='1322' dateline='1297297347'] KEJR - what firmware and IDE rev are you using? In the past I have used IDEs/firmwares ranging from the July release on up with MACRO. [/quote] I am using: IDE 1.1.2.45 (9/28/2010) Firmware: 1.2.1.5 Note: I can access macro ivars, just not anything after i999. Unfortunately the Copley amp parameters for macro start at i1024. Thanks, KEJR
Link to comment
Share on other sites

[quote='KEJR' pid='1325' dateline='1297348416'] IDE 1.1.2.45 (9/28/2010) Firmware: 1.2.1.5 [/quote] You could try moving to the February release firmware and IDE - MACRO support is getting better. The one caveat is that if you bgcplcs you may need to change the typecasting in your code to make it compile - I had to. The new IDE has gone to a C++ compile of the bgcplcs rather than a C one. It may be that the ppmac is doing something like querying the macro device, and setting what commands are allowed based on that. If so, the Copley amp may not be accurately mapped. I'll ask.
Link to comment
Share on other sites

Hello, Where is the Feb release? I went to the link in the "latest versions" thread and the latest version I can see is July 2010. Are you saying that the "Background programs" are now compiled with g++ instead of gcc? I've been wanting OOP on this thing since I've started with it but couldn't justify ditching the IDE to get it. If so I am pretty happy!!!!! Thanks, KEJR
Link to comment
Share on other sites

[quote='KEJR' pid='1332' dateline='1297374469'] Hello, Where is the Feb release? I went to the link in the "latest versions" thread and the latest version I can see is July 2010. Are you saying that the "Background programs" are now compiled with g++ instead of gcc? I've been wanting OOP on this thing since I've started with it but couldn't justify ditching the IDE to get it. If so I am pretty happy!!!!! Thanks, KEJR [/quote] because they are listed in alphabetic order, January 2011 comes before July 2010 in the latest release lists - look again. Yes - g++ now. Davis
Link to comment
Share on other sites

Davis and KEJR, We are passing the Background C Programs through C++ complier since it provides better syntax checking. The Background C programs in the end are complied with GNU C compiler and we don't have C++ support for Power PMAC yet. On reading MACRO slave variables, using MacroSlave commands, released in firmware version 1.3 you can access MI variables numbered up to 1999. Regards,
Link to comment
Share on other sites

On reading MACRO slave variables, using MacroSlave commands, released in firmware version 1.3 you can access MI variables numbered up to 1999.

 

 

Firmware from 2/10/2011 can access up to 4095 MI vars.

 

 

Link to comment
Share on other sites

because they are listed in alphabetic order, January 2011 comes before July 2010 in the latest release lists - look again.

 

I am at home now and can see the Feb 2011 folder. I'm 99% positive that the folder was not there this morning from my work computer. Not sure if permissions apply or if the folder went missing for a while, or I am crazy.. maybe all of the above.

 

Thanks,

KEJR

 

Link to comment
Share on other sites

Just to confirm, Feb2011 folder still not visible in FTP in internet explorer 8. It is visible from my FTP client built into windows file manager, so I am not sure what is going on there. Just wanted to mention it in case others have the same issue.

 

At least I know I'm not crazy now... well... in that regard at least.

 

KEJR

Link to comment
Share on other sites

Just to confirm, Feb2011 folder still not visible in FTP in internet explorer 8.

 

Ummm - I am seeing it in IE 8.0.7600.16385. Maybe you've got the old directory in the cache? Try refreshing to see of it comes up?

 

Davis

Link to comment
Share on other sites

 

Maybe you've got the old directory in the cache? Try refreshing to see of it comes up?

 

Yeah, it must have been the cache. I hit refresh and it came up. Anyhow, I'll be using the FTP client from now on!

 

Thanks,

KEJR

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...