Jump to content
OMRON Forums

A problem about SENDx in CLIPPER


guonaldo
 Share

Recommended Posts

"If I62 is set to the default value of 0, these messages are terminated with a . If I62 is set to 1, the

is suppressed. With I62 set to 1, if it desired for a Turbo PMAC program to cause a to be

sent, the SEND^M command must be used (the carriage return character is )."

 

But in my clpper board,when I type a plc program as follows:

 

I62=1 SENDS “1“ 

 

From COM3 , I get "02 31 0D"(in ascII),where do 02 and 0D come from?

 

However,I changed the program :

 

 

I62=0 ; SENDS “1“ ; 

 

And again I get "02 31 0D"(in ascII).

 

So my questions are:

1. How can I surpress 02 and 0D in COM output?

2. I62 doesn't work.Is there something else I forgot ?

 

Thanks

Guonaldo

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Guonaldo,

 

The 0x02 is a or a bell character. You can disable sending it with setting I64=0. For suppressing the 0x0D or you can use I62. Note that PEWIN32PRO2 will change your settings, so for testing this don't use PEWIN32PRO2 and issue a save and $$$ after changing I62 and I64.

 

Regards,

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...