Jump to content
OMRON Forums

Coordinate System problems


wfsteele
 Share

Recommended Posts

I have run across what appears to be a firmware bug involving coordinate system definition. I was able to recover by resetting the PPMAC, but it is somewhat worrisome that (seemingly innocuous) actions can result in failure. I am using 3 motors, #'s 4, 5, and 6. I set up 2 coordinate systems, 1 and 2. I put motor 4 into CS 1:

&1#4->{scale factor}yy

And then 5 and 6 into CS2:

&2#5->{sf}xx

&2#6->{sf}zz

Then I tried moving the motors with axis commands:

cx yy {value}

cx xx {value}

cx zz {value}

moving the yy and xx axes worked fine, but when I tried moving zz, gpascii crashed with a segfault. Experimenting, trying to find something that worked, I eventually wound up changing the CS definition for &2, using axis yy instead of zz for motor #6. I was then able to move motors 5 and 6 with the axis commands for xx and yy. But things still were not right. The first anomaly that I noticed was that the reporting command:

&2p

would return axis positions for the xx and yy axis, as it should, but also returned a position (zero) for the zz axis, which no longer existed in the CS definition. But, still, things worked OK, ... for awhile. I'm not sure what might have happened to change things, but after awhile I noticed that the axis commands no longer worked; typing a command like:

&2cx yy {value}

would do nothing at all, no error, no motion, all status indicators (closed loop, phase found, homecomplete, etc.) OK. At this point, the command &2p returned the message: 'no data to report'. I checked the CS definitions in the IDE and it all looked correct. So I had no recourse other than to reset the PPMAC. After the reset, everything worked fine.

 

I'm not sure if trying initially to use the zz coordinate was what got me into trouble, but the project I'm working on is on a tight schedule so I can't afford to spend much time trying to figure this out. But I thought I should at least report the incident.

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

wfsteele,

 

We are aware of this bug and it has already been fixed. Out next release of firmware in July will include the fix. Thanks for reporting it. I will forward you a pre-release version of the package so you can continue with your project before the actual release.

 

Regards,

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...