Jump to content
OMRON Forums

change of PLC buffer size


lukewang
 Share

Recommended Posts

Hi PMAC Support,

 

I am using Clipper. Now with inceasing size of PLC1, clipper reports an error "no room in buffer for command". When this error occurs, the size and address of the other buffers are messed up. If I delete a few lines in PLC1, everything goes back normal.

 

I just wonder anyway to increase PLC1 buffer size and how?

 

Thanks.

 

Luke

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Charles,

 

Thanks for your reply. I did that already, still the same error. I think it is not due to gathering data issue, my PLC1 is simply too big. I just wonder, besides shifting code to other PLCs, if i can increase PLC1 buffer size?

 

Thanks.

 

Cheers,

 

Luke

 

Before downloading your PLC, issue END GAT DEL GAT CLOSE.

 

For example:

 

End Gat
Del Gat
Close

Open PLC 1 Clear

/* PLC Contents */

Close

 

 

Link to comment
Share on other sites

This may be the result of actually exceeding the extent of the Clippers standard PLC memory. You can use the compiled PLC memory to access more memory that the Clipper has. To use this specify “OPEN PLCC n” where n is the PLC buffer number to use.

 

Depending on the current memory option you have you may be able to order the Extended Memory Option, “5x3”, where x is the processor speed, to get more memory.

 

You can get a little added room by compiling some or all of your PLC programs, which moves them into the separate program memory bank, and by buying the battery-backed memory (Option 16) and moving the P & Q-variables into the BBRAM by setting I46 to 3 (this frees up 8k words).

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...