Jump to content
OMRON Forums

Not receiving interrupts from PMAC


kash
 Share

Recommended Posts

I have enabled interrupts for my PMAC and included several interrupts in the terminal (PEWIN) interrupt mask. However, I never seem to receive any interrupts (not even host requests).

 

What could be the problem?

Link to comment
Share on other sites

  • Replies 16
  • Created
  • Last Reply

Top Posters In This Topic

I have tried this with our latest Executive, Pewin32Pro2. I can see all interrupts in the "Interrupt Monitor". Besides setting the interrupts to view in the "Terminal" menu "View Interrupts" selection, you must also turn on the interrupts in the Pcomm driver.

 

From the PMAC devices window (under "Setup" then "General Setup and Options") select the PCI device and then "Properties...". Then in the "Device Properties" window select the "General" button and check the "Enable Interrupts" check box.

 

You will then need to close the Executive and reboot the computer. The interrupts should now display in the "Interrupt Monitor".

Link to comment
Share on other sites

I have followed your suggested steps, but I still get no interrupts.

I can confirm that the "Enable Interrupts" check box is checked, and that the terminal is set to view interrupts.

 

I am now trying with a plc that should fire IR6, but when I use it, I get nothing.

 

; IR6 setup
M213->X:$78403,9,1 ; CTRL1 direction register
M4123->X:$78407,9,1 ; CTRL1 sense inversion control

M213 = 1 ; Set CTRL1 as output

open plc6 clear

; Trigger IR6 interrupt
M4123=1
M4123=0

displc6

close

Link to comment
Share on other sites

The Executive version is: 4.2.12.2

OS: Windows 7

I have only two systems available right now (the third is off running in a field experiment). I have run the "sid" command on the two available systems to obtain the following id's (is that enough?): 6C00000028B59124, D00000001F0AAA27

Link to comment
Share on other sites

  • 4 weeks later...
Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...