Jump to content
OMRON Forums

Help setting Sys.MaxRtPlc


dennisg
 Share

Recommended Posts

I am trying to increase Sys.MaxRtPlc from 1 to 3 via the IDE window Delta Tau->Configure-Setup Variables. It will change but reverts to 1 as soon as I try and run a PLC. I am obviously not using this correctly but I'm at a loss to figure out how to get the change to take.
Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Please make sure to click some where else (leave the drop-down list) so the value to be sent to PMAC. You can check the actual value of the Sys.MaxRtPlc in the terminal window. I have checked this and it is working fine for me.

 

Thanks Sina, I see it in the terminal window and it appears to change to 3 when I input sys.maxrtplc=3. However when I subsequently load mt PLC that is set to 2 via open plc 2 and look at the task manager, it shows up as a PLC instead of an RTPLC. I do have two other PLC's loaded with it and they are numbered 0, and 1.

Link to comment
Share on other sites

Hi Dennis,

 

I tried the following:

 

 

1. Made 5 files under my script PLCs numbered as PLC 0 .. 4.

2. Each PLC increments the P-variable matching the PLC number.

3. Download the project.

4. Set Sys.MaxRtPlc = 3 and enable plc 0..4

 

The task manager reports back with proper distinction between the background PLCs and foreground ones.

Also, the speed at which the P-variables increase indicates the foreground vs. background execution frequency difference.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...