Jump to content
OMRON Forums

Mimimum Move Time on PowerPMAC for a Real-World Application


MatthewDean
 Share

Recommended Posts

Delta-Tau Support,

 

Does anyone have a good feel for the minimum move time we can achieve using the PowerPMAC on a real-world application?

 

We have a 4-axis system that runs in LINEAR mode and uses lookahead. We have our servo rate set to 9kHz and would like to set our TA and TM times as small as possible. Right now we get coordinate system runtime errors when we set them below about 3ms.

 

Does this seem like a reasonable limit, or could we have some other setting on our PowerPMAC limiting us?

 

Also, if this is the limit, what other options do we have for a faster trajectory update? I was thinking about injecting an offset into the commanded position every servo-cyle like we used to do on the old Turbo PMACs.

 

Thanks,

 

Matthew Dean

Coastal Controls

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

I am not having any trouble running moves down to 0.15 msec in this configuration, and we do have people using block rates like this in the field.

 

I am trying to figure out what settings you might have that are limiting your block rates. If you look at the IDE's task manager, what kinds of percentage times does the processor have in phase, servo, and RTI at 3 msec block rates?

Link to comment
Share on other sites

Curt,

 

That is what I was hoping you would say. I guess I need to tweak some settings on my PPMAC to get it running faster. My processor usages are actually quite low (25% or so) when I look in the Task Manager, so I think the PPMAC has the speed to handle this.

 

I'm guessing that sometimes the processor gets busy doing other things (like handling host communication?) and it causes a momentary delay which leads to the runtime error. I'll post again when I find the exact problem.

 

Thanks,

 

Matthew Dean

Coastal Controls

 

 

I am not having any trouble running moves down to 0.15 msec in this configuration, and we do have people using block rates like this in the field.

 

I am trying to figure out what settings you might have that are limiting your block rates. If you look at the IDE's task manager, what kinds of percentage times does the processor have in phase, servo, and RTI at 3 msec block rates?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...