Jump to content
OMRON Forums

IDE EtherCAT tasks will not start


andyf
 Share

Recommended Posts

It seems the IDE (v1.5) EtherCAT support for enabling tasks does not work. It always returns an error stating that the servo period is not a multiple of 62.5 us. It is true that the Sys.ServoPeriod is not exactly a multiple (i.e. 0.24998645557832 ms), but this is due to how PPMAC calculates things. Using ECAT[0].Enable=1 is a work around, but I would expect this function to work properly in the IDE.

 

See attached screen shot...

ethercat_screenshot.thumb.jpg.42433f84ed4f5df3c5ba96262e20ccc3.jpg

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

By specification etherCAT device needs the clock to be multiple of 62.5 usec as said in the message box. You can set the clock from the clock settings page i.e. by selecting the PowerPMAC node. This will help you to set the exact required clock. In your case it must be 250.

If we don't check the etherCAT functionality won't work correctly.

By forcing ecat[n].enable = 1 from terminal may result some function will not work.

We are following the specification.

Thanks,

Atul

Link to comment
Share on other sites

Atul,

 

I originally followed the directions in the EtherCAT setup guide to set Gate3 PhaseFreq=12000 and ServoClockDiv=2 to achieve a 250us clock. After your reply, I additionally used the PMAC system setup window to adjust the global clock from 12.001 kHz to 12.000 kHz. After that, I no longer received the error message when starting EhterCAT tasks. Interestingly, if I go back to the PMAC system setup window it reads 12.0001 kHz again. It's not clear to me what this additional step did to solve the problem, but it would be good to document it in your guide.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...