Jump to content
OMRON Forums

IP address lost and recovery?


biocat
 Share

Recommended Posts

I have a Power PMAC which has worked normally. After I powered cycle Power PMAC and re-plugged the Ethernet cable, I found its IP address lost. To get the real IP address from Power PMAC, I used a USB memory stick and rebooted Power PMAC. The folder 'PowerPmacIP' was empty. No data saved in USB memory stick. Same as SD memory card. I have no RS 232 handy to try it. But I'm afraid it lost IP address already. What should I do? Can I assign an IP address to it? How to do it?

 

In users' manual, it said an IP address entered by user in IDE does not set or change the IP address of the Power PMAC; it simply specifies the IP address at which the IDE will attempt to communicate. After I set IP address in IDE and click 'Apply permanently' button, the Power PMAC IP address was changed or not. Why I can't find its IP address? Even I tried the default IP address, 192.168.0.200 to connect by Ethernet, it didn't work either.

Link to comment
Share on other sites

  • Replies 10
  • Created
  • Last Reply

Top Posters In This Topic

I had a similar problem where I couldn't communicate with the Power PMAC, and I finally solved it by reading debug messages printed to the serial port (it turned out the RAM wasn't fully seated in my case).

 

The fastest way to debug those "no boot" problems seems to be via the serial port. Just plug in an RS232 cable, open up PuTTy (or a similar terminal), and power on the Power PMAC. You should get a stream of information that will help you figure out what is going on.

Link to comment
Share on other sites

I use 115200 baud rate, 8 data bits, 1 stop bit, None for parity, and XON/XOFF for flow control. That output you are getting looks very strange, I'm not sure what is going on there. I attached an image of what my console looks like on powerup.

 

Wonderful! Thank you! 115200 works. I used 9600 wrongly. I guess my kernel has problem. It keeps rebooting in every 180 seconds.

Untitled.thumb.png.6ae805dd8bd7dec736095e08ed6491c8.png

Link to comment
Share on other sites

Someone from Delta Tau could probably give you much better help with this than I could...

 

Just out of curiousity, have you made sure that the little mezzanine card mounted on the front of the Power PMAC is fully seated and screwed down? This is the card that the SD slot is mounted to, and it also contains the flash chips that the root filesystem reads from. Worth a shot!

 

It has three small screws on the top of the card that keep it seated.

Link to comment
Share on other sites

Biocat,

 

Completely out of the blue, I had EXACTLY the same issue as you today. I was testing some new code on a PPMAC that I've used for over a year, and the processor hung. After rebooting, the kernel panicked and would not load the file system. To fix it:

 

1) Remove the mezzanine board from the bad Power PMAC

2) Wait 30 seconds

3) Reinstall the mezzanine board on the bad Power PMAC

4) Your Power PMAC should now be working.

 

This seems to happen consistently when a real-time thread crashes. Not sure why this happens though....

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...