Jump to content
OMRON Forums

Turbo Pmac 1 VME Loss position


Recommended Posts


we have the problem in subject...

occasionally happens that the TP1 loses the position of the axis, the cards are inserted into a rack GE Fanuc 90-70, and have the accessory 24, firm CPU 1.947

- we have all changed and cards.

- we have changed the cable of the optical scale

- check noises

- inserted Heidenhain PWM8 after the optical scale, detect the loss position, the optical scale seems good.

The strange thing that the variation is always a multiple of 2, 16,32,64 cts, we have many other machines with the same system, this is the only one with this problems.

You have any suggestions??

Thank you

Link to comment
Share on other sites

  • Replies 12
  • Created
  • Last Reply

Top Posters In This Topic

These type of "occasional" problems are tough to narrow down.

It appears you have done what makes sense in replacing key hardware parts.

-So it is really a case of "process of elimination".

-It is either a Hardware failure perhaps intermittent or a noise issue.


-Since it has run for some time with no noise issues this is not likely unless there has been some change such as replacing cables ? Also since the error is some multiple of 2 seems less likely to be random noise and more likely some hardware line issue such as a pull-up resistor failing and resulting in some loss of 2,4,8,16 bits being added to the count.


-More likely I think is a Hardware issue, but if intermittent it would test out fine but later cause a problem.


-Have you replaced the system power supply ?

-look closely at the 5v encoder supply to be sure 5v... not sagging at all

-chk the grounding of 5v supply and differential wiring from the scale to encoder inputs...

- replace the power supply in GE 90-70



-You replaced the PMAC ?

-did you swap it with a known good say from another machine ?

- or is is a older spare off the shelf ?

- is is NEW or used ?


-One way to narrow this down would be to bring the encoder signal from the scale to a Secondary channel ALSO counting at the same time.

-Do you have a extra motor channel on this system now not being used such as a Motor #8 ? If so you could wire the encoder input in parrallel to this channel then look for the error to occur. If it duplicates on both channels than the issue likely in the signal to the PMAC, not in the PMAC.

Otherwise it looks like a PMAC issue.


How often does this error occur ?

-every hour, 10 min, once a day, week.... ?


How do you detect that it has happened ? machine problems ?

Link to comment
Share on other sites

This is my first reply to a message- Sorry if its format does not come out OK!


If your TP1-VME has been operating successfully in the 90-70 rack and then has all of a sudden become problematic for an encoder, you might wish to check a few minor things in your rack.


Perhaps you should try reseating the power supply board, processor board and cleaning any dust from the front and rear of the backplane, power supply and processor card. Also verify that the power wiring is snug at the terminal blocks on the back panel of your machine. Don't forget to check the green wire ground bonding terminal strip too...


The same should be done with the wiring on the encoder if it is connected to terminal blocks in different parts of the machine.

Link to comment
Share on other sites

When you lose counts in powers of two it sounds like you are getting a false signal on one pin of a parallel feedback word (i.e. lsb, lsb+1, etc). However you mention Acc-24. What type of feedback are we talking about?


I once had a problem where bad cabling was causing a similar problem, which caused a huge jump when it was the 2^16 bit.

Link to comment
Share on other sites

  • 3 weeks later...

add more information,


- the problem occurs on two different cards, inserted in two different rack GE, 1 and 2.

- the transducers are linear scales TTL Heidenhain LS 473C (LS 477C) or outputs simulated by Bosch drives for spindles.

- as said before ALL PMAC cards have been replaced and the power supply of the rack GE.

- the optical scales and cables have been replaced.

- the error occurs on average monthly :(


we have 200 other machines with the same configuration,work fine.

Link to comment
Share on other sites



If you have a series of machines that has been getting no errors and then you end up with 2 machines that are showing the problem, I would tend to ask a couple of odd questions...


Such as-

1. Are the problematic machines built around the same time approximately?

2. Is there anything that is uniquely different between a machine built like the problematic ones and the other majority of machinery.


When you look at the machine for problems like this take into account the way that the interface cables are routed between the ACC-24V and the PMAC-VME. I think that you indicated that they have been replaced. Be sure that they are as short as possible...


If the problematic machines were built around the same time, could there be a unique wiring change that is causing a ground loop between the encoder processors and the ACC-24V.


Unit101 referred to checking the grounding between the encoders, 5V supply and the controller. Insure that the connections are present and that they are tight. If the machines are just a couple of units that have been operating in the field for a while, then vibration and galvanic corrosion can affect the ground bonding around the machine. A ground loop can make the ACC-24V and PMAC interface flaky...

Link to comment
Share on other sites

Once again I mention that powers of 2 indicate parallel data and not quadrature. I don't know your hardware, but clearly the problem is with a digital signal / parallel word, or an internal register. If you have an issue with serial device like a quadrature encoder, you get any number of missed counts. Also, the counts tend to be missed, i.e. the machine comes up short. Parallel data / powers of 2 error can have any polarity. This should help narrow down where the error is entering the servo loop. Of course, the cause of the noise could be many things.


I once had the same problem with a VME PMAC and a 14V parallel feedback card where any one of the bits could fire. We never solved it, I am said to say, but it was isolated to one machine.

Link to comment
Share on other sites

  • 1 month later...


the other day we worked on the machine, we connected the Fluke 435 Energy Analyzer and we moved the jumper from E34a to E35, ( Encoder Sampling Clock Frequency Control) the Pmac 0 not it enabled axes, we had to put the jumper on e34a to run the machine, it is the first time that we are experiencing a thing so strange...

some ideas?

Link to comment
Share on other sites

  • 5 months later...

Hello guys , looks like we are on the right way to solve this problem.

A few moths ago we moved the jumper E 34 to E35 (encoder sampling frequency) but the errors were worst , so we went in the other direction moving the jumper to E34A which is the fastest encoder sampling frequency.

At the same time we tried to increase the pmac frequency from 60 MHz (I52=5) to 80 MHz (i52=7) but again the errors were worst , so we went in the other direction with 40 MHz (I52=3).

With this configuration I52=3 and the jumper for the encoder sampling frequency put on E34 we are experiencing no errors for the last 2 months , hopefully we are on the right way , what do you think ?Does this make sense to you ? For us it make no sense but looks like it works !!!

Link to comment
Share on other sites

This is sounding more like a memory "data" issue. If it is always off by a power of 2 this would indicate a bad bit of data. Also changing the CPU speed lower seems to make it better.


What is the firmware version and the part-number of the CPU?

This could be a compromised CPU board.

Link to comment
Share on other sites

  • 1 month later...
This topic is now closed to further replies.

  • Create New...