Jump to content
OMRON Forums

stepper position not incrementing


mjunker
 Share

Recommended Posts

I cannot seem make the position and velocity output on motor channels 25 and above. The position error is incrementing correctly but the position and velocity address seem to be not be mapped correctly. All of the other motors are working properly. I am using internal stepping from the ACC-24E2A card.

 

I have a Delta Tau MACRO setup with 2 16-axis MACRO CPU's (2 macrostations) communicating over fiber with a MACRO Ultralite Turbo PMAC2 VME board with 4 servo IC's.

 

I have followed consistent mapping of the Ixx02, Ixx03, and Ixx04 variables but cannot find what the problem is with the output position. The MS{node},MI910 variable is also correctly set to internal feedback as well.

 

I am using

I2502=$7B422 (+2 for stepper output)

I2503=$3532

I2504=$3532

as described in the software reference manual.

 

I also have MS48,I916=2

 

I have been trying to sort this out for over a year now and it still is not working.

 

Cheers,

Mark

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Your PFM settings make sense, but it is possible that you have a fundamental MACRO set up issue.

Can you enable the axis? (hear the relay click on the ACC-24E2A, and see the amplifier enabled bit in the motor status window)?

Do you see the following error increase (but the actual position steady) if you issue a jog command?

 

Share more of your settings if you like, and we will take a look at them. Encoder Conversion Table settings, nodes enabled on both controller and station, I2500 through I2599. Also, You must have done some custom mapping. I don't understand how is motor #25 node 48 for you. We usually recommend using default mapping provided by the firmware.

 

Say I have an Ultralite with 1 x servo IC, and 1 x MACRO16 Station with an ACC-24E2A. Setting up Motor #5 (skipping the 4 local motors) as internal pulse and direction requires:

- Setting up MACRO communication, clock settings, error check

- Enabling node 0 (which corresponds to motor #5 in this example)

 

The only changes needed from these default settings are:

I500 = 1		 ; Activate Motor
I524 = $60001	; Disable Over-travel limits

MS0,I916 = 3	 ; Set output mode to C PFM
MS0,I910 = 8	 ; Set encoder/decode to internal pulse

I502 = $78422	; Set output register to PFM

 

These settings should be sufficient to jog the motor.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...