Jump to content
OMRON Forums

EtherCAT help..


naguiman
 Share

Recommended Posts

Hello~

 

I am setting EtherCAT Drive (Sanyo Denki R Advenced)

 

I have question..

 

1. I type terminal window 'ecat config' when I connect AKD EtherCAT drive

 

Slave 0 PDO

-------

Index=$6062 Subindex=0 length=32 output

Index=$6040 Subindex=0 length=16 output

Index=$6064 Subindex=0 length=32 input

Index=$6041 Subindex=0 length=16 input

 

and,

2. I type terminal window 'ecat config' when I connect Sanyo Denki EtherCAT drive

 

Slave 0 PDO

-------

(nothing)

 

why different two drive return info?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Hello~

 

I am setting EtherCAT Drive (Sanyo Denki R Advenced)

 

I have question..

 

1. I type terminal window 'ecat config' when I connect AKD EtherCAT drive

 

Slave 0 PDO

-------

Index=$6062 Subindex=0 length=32 output

Index=$6040 Subindex=0 length=16 output

Index=$6064 Subindex=0 length=32 input

Index=$6041 Subindex=0 length=16 input

 

and,

2. I type terminal window 'ecat config' when I connect Sanyo Denki EtherCAT drive

 

Slave 0 PDO

-------

(nothing)

 

why different two drive return info?

 

Hi,

Did you use the Setup tool to setup etherCAT devices ?

Our IDE setup tool support EtherCAt device settings. I suggest you should use the setup program. We have tested the Sanyou Denky drive and works fine. If you don't see the PDO then you need to get the device XML file from the vendor.

We will post the IDE manual either today or tomorrow on the Forum that covers the EtherCAT setup tools.

Let me know if you have any question.

Thanks,

atul

Link to comment
Share on other sites

Hello~

 

I am setting EtherCAT Drive (Sanyo Denki R Advenced)

 

I have question..

 

1. I type terminal window 'ecat config' when I connect AKD EtherCAT drive

 

Slave 0 PDO

-------

Index=$6062 Subindex=0 length=32 output

Index=$6040 Subindex=0 length=16 output

Index=$6064 Subindex=0 length=32 input

Index=$6041 Subindex=0 length=16 input

 

and,

2. I type terminal window 'ecat config' when I connect Sanyo Denki EtherCAT drive

 

Slave 0 PDO

-------

(nothing)

 

why different two drive return info?

 

Please use the IDE as Atul suggested. However, to directly answer your question the the PDO's displayed are the defaults that are programmed into the device.

 

Some vendors will place PDO info in their device by default and others will not. If they do not you must use the setup program and load the vendors XML file. The IDE will use the vendor XML file and load the PDO information.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...