Jump to content
OMRON Forums

Turbo PMAC Firmware Download Link


nalin_208
 Share

Recommended Posts

I have Turbo PMAC CPU (3x0-603766), in which WatchDog LED is continuously light up, due that i am not able to communicate with CPU through USB cable. i think firmware reload will solve the problem.

 

i need to download firmware in it, after referring forum, i found that firmware is located at C:\DeltaTau\Firmware, but in my case firmware directory is missing (See the attachment), is there any other way or link from that i can download required firmware (i.e. Turbo2.bin file)

TurboPMAC.JPG.6db69fa964a2129ef59fb2d08a0576f6.JPG

Link to comment
Share on other sites

  • Replies 12
  • Created
  • Last Reply

Top Posters In This Topic

have you tried to use E3 jumper to set everything back to factory default values for reset?

 

If this resolves the watchdog problem, then it's something wrong with your original setting, and it has nothing to do with the firmware.

Link to comment
Share on other sites

Thanks for prompt reply,

i had already tried E3 jumper (Re-Initialization Jumper), in that case Watch Dog LED was gone, and i was able to communicate with CPU, but after removing E3 jumper, problem was as it is (Watch Dog LED lights up again).

 

i had also tried E19 (Watchdog Timer Jumper), in that case also situation was the same, after removing jumper Watch Dog Again lights up.

 

actually problem was occurred due to power break while downloading program with laptop (Windows -7 operating system, normally we use WinXp, but this time we were trying windows 7 and power break occurs.)

 

after that watch dog LED lights up in next restart.

 

i think the main problem is firmware, and same will resolve the issue, but my problem is i can't found TURBO PMAC firmware (TURBO2.bin) anywhere.

 

Other thing is that, while search for Turbo PMAC firmware i reach to following thread

 

http://forums.deltatau.com/showthread.php?tid=63&highlight=firmware.

 

where i had found "PETHUSB307FX2.zip" as firmware. but i think it is not watch i was searching for.

 

so could you please help to guide, where i can find my required firmware (TURBO2.bin)

 

My CPU number is :: 3x0-603766

PETHUSB307FX2.thumb.jpg.bcabd1a0b2afacaa3aa1b08cb2a49651.jpg

Link to comment
Share on other sites

Did you issue a save, followed by a $$$ while E3 is installed? You would need to do that to maintain the factory reset on the board. Don't use E19, its not a reset jumper.

 

The files you are showing are USB/Ethernet communication files. Do not use those.

 

Turbo2.BIN firmware files are not public. Please email tech support to send you the latest version (1.947).

Link to comment
Share on other sites

thanks again for prompt reply,

i had tried to reset it by $$$***, but it don't works... still problem is same...

as you are telling TURBO2.bin is not public file, then why one of the forum thread is telling that you will find your required firmware in your installation directory "C:\Deltatau\Firmware\VS1.939" (Please refer the following thread)

 

http://forums.deltatau.com/showthread.php?tid=65

 

what is email address of Tech Support Team.

Turbo2Req.thumb.jpg.1220e47d8428fde780d0c2086147883e.jpg

Link to comment
Share on other sites

I did not say anything about a $$$***! I asked if you had issued a SAVE (while E3 is installed), followed by a $$$ or power cycle.

 

The above post is just an EXAMPLE. It clearly states "TURBO2.BIN which WAS stored in the C directory"... By the user.

 

The technical support information is on our website. The tech support e-mail address is: support@deltatau.com

Link to comment
Share on other sites

sorry for the late reply, i was out of station..

 

i had tried E3 jumper, but this time WD LED just light up with E3 jumper just installed, i had tried to communicate with PEwin32Pro but it shows, PMAC could not be detected.... i had tried lot of times but problem is same.....

 

then after i tried power cycle (Switch ON and OFF main Supply), but still problem is same......

 

one thing i want to ask, is there any way that i can upload firmware form Turbo PMAC ? , i have one spare PMAC which is working fine, i am thinking that if i can upload firmware from it, then save it and download it to faulty PMAC...

 

i have also emailed support team, waiting for their reply...

Link to comment
Share on other sites

As you said, if WD LED lights up during E3 jumper installed, then it is hardware failure.....in that case i have only one question left, if i install E23 (Firmware Reload Jumper) then why my WD LED is gone, system is able to detect PMAC and asking for firmware.

 

i just want to take chance, to reload required firmware, i had already mailed support team.... but still as on date i have not received any reply from support team....

 

what about other thing, ... upload firmware from healthy PMAC....is there any way for it???

Link to comment
Share on other sites

Hi,

 

We are a bit confused now.

in one post you mentioned that when E3 jumper is installed, the problem went away.

But in this post, you said even with the E3 jumper installed, the WD LED is still red.

 

The other thing is, when you said "system is able to detect PMAC and asking for firmware", did you install E23 jumper?

Because unless you use a firmware reload jumper, PEWIN should not ask you the firmware.

 

Here is the logic for E3 initialization jumper:

 

there is a memory location that has all default values of variable settings, and when E3 jumper is installed, PMAC will use this setting on power on.

But, if you did not issue a "SAVE" command when you communicate to PMAC, then the factory default will not be saved in flash memory, which means when you remove E3 jumper, PMAC will use whatever is in the original flash memory instead of factory default setting.

 

Like Richard mentioned, if with E3 jumper installed and you still have a WD LED red, then there is some hardware issue and it won't be fixed by re-installing the firmware.

 

Of course, if you reinstall the correct version of firmware with E23 jumper on, then it might fix the problem since this will set everything back to factory default even with E3 jumper off.

 

Please make sure you understand what the real problem is and use a proper approach to resolve it.

 

Jay

 

As you said, if WD LED lights up during E3 jumper installed, then it is hardware failure.....in that case i have only one question left, if i install E23 (Firmware Reload Jumper) then why my WD LED is gone, system is able to detect PMAC and asking for firmware.

 

i just want to take chance, to reload required firmware, i had already mailed support team.... but still as on date i have not received any reply from support team....

 

what about other thing, ... upload firmware from healthy PMAC....is there any way for it???

Link to comment
Share on other sites

Present status of my CPU is as follows...

No Jumper (E3/E23) : WD Lights up red and not able to communicate with CPU through USB cable....

E3 (Re-initialization) Jumper : WD Lights up red and not able to communicate with CPU through USB cable....

E23 (Firmware Reload) Jumper : WD LED goes away, PEWIN32 Pro device detection is ask for firmware.....

 

yes you are right, in one post i had mentioned that whenever i install E3 jumper then WatchDog LED goes away.... but by mistake we had tried to load other firmware in PMAC. ( USB/Ethernet communication ) firmware which is already mentioned in post # 3, after that E3 jumper is also not working (i.e. WD Led lights up with E3 Jumper installed and system is not able to communicate with PMAC through USB cable.)

 

please help me get my required firmware, as you said correct firmware will might solve our problem....

 

please let me know, is there any other way i can upload the firmware from Healthy TURBO PMAC CPU, as i have one spare healthy Turbo PMAC CPU, which is working fine....

Link to comment
Share on other sites

Dear Jay and Richard,

 

Thanks a lot for your kind support, because of you peoples, i have saved my CPU,

 

i got my required firmware from support team through Email....

 

Firmware is working fine, and no more Watch Dog is coming....my all programs are working fine......thanks a lot once again.....

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...