Jump to content
OMRON Forums

Maybe a bug of MACRO 16-axis station


aTURBOPMAC2USER
 Share

Recommended Posts

Hello, I have a big problem of MACRO 16-axis station. My pmac framwork is:ultralite pci + 16-axis macro + 3 acc24e2a.

The following code is the configuration file. After downloading the code, 1-8 axes work fine, but 9-12 axes (the third acc24e2a) don't work.

I6840=$4030
I6841=$FB333
I6890=$90
I6891=$1FB333
I6940=$10
I6941=$2F8001
I6990=$10
I6991=$3F8001

I70=$3333
I71=$3333
I72=$3333
I73=$3333
I78=32
I79=32
I80=100
I81=2
I82=2

I100,16,100=1				//Enable Motor 1-16;
I116,16,100=50			//Max Vel 50000cts/sec;
I117,16,100=1				//Max Acc 1cts/sec^2;
I119,16,100=1				//Jog Acc 1cts/sec^2;
I122,16,100=50			//Jog Vel 50000cts/sec;
I124,16,100=$160001	//Disable Limits And Amplifier,Only For Pulse And Direction;
I130,16,100=2110		//Proportion Gain,Only For Pulse And Direction;
I131,16,100=0				//Derivitive Gain,Only For Pulse And Direction;
I132,16,100=5000		//Vff Gain,Only For Pulse And Direction;
I133,16,100=0				//Integral Gain,Only For Pulse And Direction;
I134,16,100=1				//Integration Mode,Only For Pulse And Direction;
I135,16,100=0				//Aff Gain,Only For Pulse And Direction;
I169,16,100=2184     //Max Effort Command Out Of Maximum 32767,Only For Pulse And Direction;

I102=$78422					//output register (default location +2)
I202=$78426					//output register (default location +2)
I302=$7842A					//output register (default location +2)
I402=$7842E					//output register (default location +2)
I502=$78432					//output register (default location +2)
I602=$78436					//output register (default location +2)
I702=$7843A					//output register (default location +2)
I802=$7843E					//output register (default location +2)
I902=$79422					//output register (default location +2)
I1002=$79426				//output register (default location +2)
I1102=$7942A				//output register (default location +2)
I1202=$7942E				//output register (default location +2)
I1302=$79432				//output register (default location +2)
I1402=$79436				//output register (default location +2)
I1502=$7943A				//output register (default location +2)
I1602=$7943E				//output register (default location +2)

MS0,MI1996=$1FB333		//Activate Nodes 16,17,20,21,24,25,28,29;

MS0,MI910=8					//Sets Only For Pulse And Direction; 
MS0,MI916=3
MS1,MI910=8 
MS1,MI916=3
MS4,MI910=8 
MS4,MI916=3
MS5,MI910=8
MS5,MI916=3
MS8,MI910=8 
MS8,MI916=3
MS9,MI910=8 
MS9,MI916=3
MS12,MI910=8 
MS12,MI916=3
MS13,MI910=8 
MS13,MI916=3
MS16,MI910=8		
MS16,MI916=3	
MS17,MI910=8	
MS17,MI916=3	
MS20,MI910=8
MS20,MI916=3
MS21,MI910=8
MS21,MI916=3
MS24,MI910=8 
MS24,MI916=3
MS25,MI910=8 
MS25,MI916=3
MS28,MI910=8 
MS28,MI916=3
MS29,MI910=8 
MS29,MI916=3

Then I want to know what's wrong, and find that one MI variable:MS0,MI1996=$1FB333, can't be saved, as the picture illustrated.

I tried three other 16-axis macro stations in my hand, and find the problems are the same. Then I tried another ultralite pci card, the problem always appeared.

Someone told my distributor that make sure the SW1 setting is not set to 15. I checked the SW1 and find that SW1 setted to 7, and SW2 setted to 0, and ms0,mi3=$7.

The ultralite firmware version is 1.947 and Macro CPU firmware version is 1.203.

I am sure that the dial switches of the three acc24e2a are all right, and the hardwares are all right. But how to overcome this problem?

PMAC错误.bmp

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...