Jump to content
OMRON Forums

Mapping power PMAC variables Failed


vanandel
 Share

Recommended Posts

With IDE 1.5.0.21, when I try to build a project, I get the dialog:

 

Mapping power PMAC variables Failed. Do you wish to continue the build process.

 

The output window shows:

=================

Please wait while mapping Power PMAC variables.

Could not open the error file

=================

 

I'm running the IDE as a user 'lroot' with 'Administrator' privs. The 'lroot' user owns all the directories under 'Documents', and has 'Effective Permissions' to access C:\Program Files (x86)\Delta Tau Systems Inc\

 

What is the full pathname for the error file that the IDE can not open?

 

Any idea on how to fix this?

 

(Please don't ask me to upgrade to a later IDE - later versions of the IDE seem to insist on later versions of the firmware, and later versions of the firmware don't support switching an axis between jog mode and 2 axis movements, which our current application uses.)

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

(Answering my own question . . .)

Summary - my project directory was missing the 'Log' subdirectory.

 

I ran the SysInternals ProcessMonitor

(http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx)

and discovered the IDE was trying to open /Log/pp_error.log .

Once I created the "Log" subdirectory, and "Configuration\pp_disable.txt"

my builds started working again.

 

With IDE 1.5.0.21, when I try to build a project, I get the dialog:

 

Mapping power PMAC variables Failed. Do you wish to continue the build process.

 

The output window shows:

=================

Please wait while mapping Power PMAC variables.

Could not open the error file

=================

 

I'm running the IDE as a user 'lroot' with 'Administrator' privs. The 'lroot' user owns all the directories under 'Documents', and has 'Effective Permissions' to access C:\Program Files (x86)\Delta Tau Systems Inc\

 

What is the full pathname for the error file that the IDE can not open?

 

Any idea on how to fix this?

 

(Please don't ask me to upgrade to a later IDE - later versions of the IDE seem to insist on later versions of the firmware, and later versions of the firmware don't support switching an axis between jog mode and 2 axis movements, which our current application uses.)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...