Jump to content
OMRON Forums

How is User Buffer size stored / corrupted?


daves
 Share

Recommended Posts

There is something funny about how User Buffer (and I assume other project properties) is stored.

 

The message which appears when you change it is testament to this (please also note the spelling error):

 

To update the buffer settings that you recently changed, you should do the following:

 

1. Downlaod the project by using the Download All Programs option

2. Go to the Terminal Window

3. Type Save in the terminal window to save all modified parameters

4. Type Reboot in the terminal window to reboot the power PMAC.

Please be adivised that by rebooting the power PMAC, you are

shutting down power PMAC and restarting it.

 

I just wasted a day investigating a hard watchdog after upgrading to 1.6.1.1 firmware and 1.7.0.53 IDE.

 

My project sets a User Buffer of 10 and this was up and running fine. I did the upgrades (not very speedy due to complete uninstall and reinstall required - a patch upgrade solution would be more pleasant). Then we got a hard watchdog during a test. Of course I doubted the upgrade and retried. Then tried downgrading which still failed. So I doubted code changes and checked, hardware changes and checked, thermal shutdown as it was a hot day, etc

 

I finally deduced the watchdog was due to accessing USM outside the default 1MB size which my project had reverted to without telling me (still showing 10 in the project properties). This despite many combinations of $$$, $$$***, etc. Only changing it to 5, say, and back to 10 fixed it.

 

1) Why is the size not simply downloaded each time?

 

2) Why is it not checked to match project settings by the download process?

 

3) How does the firmware upgrade lose the setting?

 

4) Why does the firmware upgrade not warn me I have lost critical settings?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...