Jump to content
OMRON Forums

Encoder issues, counts going the wrong way.


Mattlyf
 Share

Recommended Posts

I have a Geo Brick LV-PC, I'm trying to setup some PI servo motors. The motors drive fine in open loop mode with #xo30, #xo-30 etc but when I drive them with a jog command #xj+, #xj- etc it goes out on following error. When I set it to ignore the error I noticed the counts are going the wrong way, so if I give #xj+ the counts go negative, if I give #1j- the counts go positive. The motor is going in the correct direction when driven.

 

I've tried swapping encoder wiring A with not A and B with not B but that made no difference, so I then tried A with B and not A with not B, this resulted in the motor not driving at all in closed loop.

 

Has anyone else experienced this or have any pointers as to where to start looking?

 

Thanks

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...