Jump to content
OMRON Forums

Linear blended move slow


Tieval
 Share

Recommended Posts

Hi all,

 

The majority of our motion is simple and is carried out by moving 2 axes to a point and indexing the remaining axes. See below:

 

OPEN PROG 1 CLEAR
LINEAR
ABS
FRAX(Y,Z)
TA180
TS90
F800
DWELL0
P96=1
Y500Z-114
DWELL0
P97=1
CLOSE

 

However, we have a new requirement to synchronise motion between 2 axes through multiple points over a line. I believe the easiest way to do this is using a linear blended move in a motion program. Please see below for my current motion program:

 

OPEN PROG 1 CLEAR
LINEAR
ABS
FRAX(Y,Z)
TA180
TS90
F800
DWELL0
P96=1
Y350Z-104.375
Y400Z-100
Y450Z-104.375
Y500Z-114
DWELL0
P97=1
CLOSE

 

This does synchronise the motion of our Y and Z axes however, it slows the motion down to a fraction of the motors capabilities. Having read the linear blended move section of the manual, I believe that the issue is caused by the fact that the PMAC treats each programmed move as the last in the sequence so it keeps the speed low so that it can come to a controlled stop. I have had relative success in speeding this up by:

 

1) by reducing TA and TS so that it can accelerate and decelerate quicker however, this does make the motion a little jumpy.

2) by reducing the number of points in the motion program thus giving the motors more time to accelerate and decelerate. The only issue is that we have less control on Z positioning during the line.

 

I have also attempted to use the lookahead feature but this seems to have a limited affect.

 

Is there an alternative method of coordinating motion? We do not require great accuracy. Speed is a more important factor and if necessary we will just reduce the number of points in the line but if there is a better method, I would like to try and implement that before opting for the easy option!

 

Many thanks

 

Ben

Link to comment
Share on other sites

  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

I would not try synchronizing motion in any other way. Your speed and or acceleration might be limited by the maximum program parameters of these motors or any motor in this coordinate system. Check your motors' Ixx16, and Ixx17.

 

Hi Richard,

 

Thanks for getting back to me. I've increased Ixx16 and Ixx17 for both motors in the coordinate system however, these variables are not what's causing the system to slow down. I also attempted the following:

 

OPEN PROG 1 CLEAR
LINEAR
ABS
FRAX(Y)
TA180
TS90
F800
DWELL0
P96=1
Y350
Y400
Y450
Y500
DWELL0
P97=1
CLOSE

 

Despite removing the Z, the speed over the scan line remained slow. The only way I could increase the speed was by removing waypoints:

 

OPEN PROG 1 CLEAR
LINEAR
ABS
FRAX(Y)
TA180
TS90
F800
DWELL0
P96=1
Y400
Y500
DWELL0
P97=1
CLOSE

 

So it would seem that the more points in the line that need to be blended, the slower the axes will travel. Going back to my original post, I believe that the issue is caused by the fact that the PMAC treats each programmed move as the last in the sequence so it keeps the speed low so that it can come to a controlled stop.

 

Does the lookahead feature allow the axes to reach maximum velocity during a blended move? I'm not sure that I used this feature correctly.

 

Thanks again.

Link to comment
Share on other sites

  • 2 weeks later...

I would not try synchronizing motion in any other way. Your speed and or acceleration might be limited by the maximum program parameters of these motors or any motor in this coordinate system. Check your motors' Ixx16, and Ixx17.

 

I had another go at adjusting TA and TS but the acceleration and deceleration at the beginning and end of the scan line ends up being too sharp.

 

I’ve tried using the lookahead feature but it seems to have had a negligible effect (maybe I’m doing something wrong). As per the manual, I’ve done the following:

 

1. DEFINE COORDINATE SYSTEM

#1->1633Z

#2->327.6Y

 

2. CALCULATE POSITION LIMITS (not sure if these are needed but I calculated these values anyway)

• I213 = 167076

• I214 = 95004

• I241 = 10

• I113 = -163300

• I114 = -195960

• I141 = 10

• Both I124 & I224 were set to $840401 (to set bit 15 to 1)

 

3. VELOCITY LIMITS

• I116 = 82

• I216 = 350

 

4. ACCELERATION LIMITS

• I117 = 2

• I217 = 3

 

5. SEGMENTATION TIME & LOOKAHEAD LENGTH

• I5113 = 6 (1000/TA)

• I5120 = 13 (I216/(2*I217*6)*1.33))

 

6. DEFINE LOOKAHEAD

• &1 DEFINE LOOKAHEAD 200,20

 

Is this a limitation of multipoint moves? We have managed to speed up scan lines by reducing the number of points passed to the PMAC. We don’t require precise motion during the scan line so we can reduce the number of waypoints. However, I would rather speed the scan lines up using the lookahead feature if possible?

Link to comment
Share on other sites

The look ahead is not your issue here. When you specify too many points the execution times for each move are very small. If a feedrate-specified move segment is so short in distance that it cannot reach its target velocity, it will spend its entire time in acceleration (yielding a triangular rather than trapezoidal profile). The minimum time for such a move is thus the specified acceleration time (the larger of TA or 2*TS).
Link to comment
Share on other sites

The look ahead is not your issue here. When you specify too many points the execution times for each move are very small. If a feedrate-specified move segment is so short in distance that it cannot reach its target velocity, it will spend its entire time in acceleration (yielding a triangular rather than trapezoidal profile). The minimum time for such a move is thus the specified acceleration time (the larger of TA or 2*TS).

 

Hi Steve,

 

This does sound like our issue. However, by adjusting TA to achieve the target velocity, the acceleration and deceleration is too sharp. Is there any way around this?

 

We have removed 2 points but would rather use 4 to achieve a smoother curve.

 

Thanks

Link to comment
Share on other sites

Please also check your Isx90 "Coordinate System x Feedrate Time Units". I think your I116 setting is too low and is limiting your speed.

 

Hi Mustafa, I've checked Isx90 and have already checked that I116 is set high enough to allow target velocity to be reached.

 

Thanks

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...