Jump to content
OMRON Forums

a problem with the filtered PWM output


Recommended Posts


everyone,I have some troubles,can you give me some advice? I have a clipper,The Clipper Board +/-10V DAC outputs are produced by filtering a PWM signal.I want to control a PMSM with the filtered PWM.

here is my code.

I7000 = 1001	
I7001 = 5    	
I7002 = 3  	
I7003 = 1746	
I7100 = 1001	
I7103 = 1746 	
I7016 = 0	
I10 = 3421867
While (p1 <10000)
 If (p1 = 10000)
   disable plc1
enable plc1

by running this program,I found that the output voltage between J3 PIN29(ADC1) and J3 pin48(GND) can be controlled by the M102 variable.But the clipper can not receive the encoder signal, when I rotate the motor by hand,the position window shows 0.0cts. then I set the I100 to 1 and rotate the motor by hand again,the position window shows the correct number of counts.BUT there is another problem,I found the value of M102 is 0 and can not be changed. I don't know why this happen,is there somebody give me some advice?

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic



Yes, Ixx00 must be set to 1 to process the encoder. This "activates" your motor functions. When you set Ixx00=1, PMAC will start controlling the PWM outputs and you cannot write to them manually. You almost never need to write to them manually, however, since PMAC will figure out the proper PWM command based on the move you want to execute. Have you tuned your motor and tried running a motion program yet?

Link to comment
Share on other sites

uh,I am a beginner ,I haven't written a motion program.yesterday I made a open loop test , the result is like this:


I have set i100 to 1,when I clicked the "open loop test"button ,my amplifier status indicator turned green(means the amplifier is enabled and operational),and the motor moved slowly,but in the picture above,it shows that the amplifier is disabled and the motor speed can not be detected. can you help me figure out the reason?

thanks a lot!

Link to comment
Share on other sites

Do you have an encoder, and if so, is it wired in properly? What kind of encoder? The default settings only work for quadrature encoders. If you have a different kind of encoder, it will require specific settings.


Please note that if you are in China (which I assume since china is literally in your username), you can contact our Chinese office for technical support questions such as these. Specifically, their support email is support AT deltatau-china DOT com. The rest of their information is below:


Delta Tau China, Co. Ltd.

C-1608 Focus Square

6 E. Futong Street,

Chaoyang District, Beijing, China, 100102

PH: (8610) 64392833/64392860

FX:(8610) 64392860x18

Attn: Ms. June Xue


EMAIL: info@deltatau-china.com

Link to comment
Share on other sites

OK,thanks a lot ,I have figured out the reason yesterday ,the enable line has been wired wrongly.It's a stupid mistake,I am so sorry to trouble you.

I correct the wiring and test again,the result is right.


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...