Jump to content
OMRON Forums

Offline build fail - SOLVED


daves
 Share

Recommended Posts

IDE 2.0.3.40

 

Spent a day building successfully to a connected 465-2. Turn off. The next day run with No Device and check if a C code change still builds I get:

 

	Build Process For librtiplcc.so has started.
C:\ABD\PowerPMAC\SPMM\Phase2\Phase2\Phase2.ppproj(400,5): Error :       0 [main] make 4172 child_info_fork::abort: C:\DeltaTau\Power PMAC IDE\compilers\bin\cygiconv-2.dll: Loaded to different address: parent(0xC30000) != child(0xC60000)
C:\ABD\PowerPMAC\SPMM\Phase2\Phase2\Phase2.ppproj(400,5): Error : make: vfork: Resource temporarily unavailable
	Build Process For librtiplcc.so has ended.

 

I'm guessing the 465-2 is peculiar? I'm sure I could go 460->No Device and build fairly successfully...

 

How do I get the offline build to work again? (I've tried Clean)

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

In case anyone else suffers this:

 

I think it was due to SOMETHING waking my Windows 10 PC from Off/Hibernate(?) at 3AM and doing some update. There were some MySQL errors, and the compilers folder under the IDE had been corrupted (not sure how but the 465-2 compiler and powerpc-465-rootfs.tar.gz were missing/damaged).

 

A Windows restart seemed to restart MySQL and copying the compilers folder from an IDE install on another PC fixed the missing APM86xxx libraries.

Link to comment
Share on other sites

  • 4 weeks later...

Thanks Tony.

My problem was different but I hit this one today after doing the 1511 Threshold 2 update.

 

(For search purposes) The message I got was

 

xxx.ppproj(431,5): Error MSB4062: The "PPMAC460CompileTask.CompileTask" task could not be loaded from the assembly C:\Windows\Microsoft.NET\Framework\v3.5\PPMAC460CompileTask.dll. Could not load file or assembly 'file:///C:\Windows\Microsoft.NET\Framework\v3.5\PPMAC460CompileTask.dll' or one of its dependencies. The system cannot find the file specified. Confirm that the declaration is correct, and that the assembly and all its dependencies are available.

 

As you say reinstalling the PPMAC update fixed it for me.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...