Jump to content
OMRON Forums

Incorrect VendorID for Amp over E-CAT


teuschbd
 Share

Recommended Posts

Running IDE 3.1.2.2

465 Power CPU: 3-4045-MA0-350-B1000

2 x AMP's (SGD7S EtherCAT) : Yaskawa_SGD7S-xxxxA0x.xml (V8.03)

1 remote IO rack.

 

tinkering with an ethercat setup using the above devices.

 

Regardless of network orientation, if the first two nodes of the network are the Amplifiers - the VendorID for the second Amplifier incorrectly identifies as vendor id 539 instead of 1337 (per the device file). However; if I interconnect the Amplifiers with the remote IO module between both Amplifiers, both Amplifiers identify correctly as vendor ID 1337. (I was able to set them up and move each motor via the jog ribbon). Removing the IO module from the network has no impact - the 2nd node will still be incorrectly identified as 539.

 

Have tried various network cables thinking it was noise or interference; the issue is repeatable regardless of Amplifier node position or cable.

Resetting All Masters, Scan Devices, Configure Master[0] does not appear to resolve the issue as well. If the second node is an Amplifier it will have an incorrect vendorID.

 

Have tried upgrading to version 4 - and found Etherlab was not yet implemented. Ran into issues with the configuration file not compiling correctly afterwards in V3x, and have since re-installed IDE 3.1.2.2.

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...