Jump to content
OMRON Forums

Full download after reset requires stepping through motor configuration every time.


jbeasley
 Share

Recommended Posts

System is PowerBrickLV, 8 Channel 5/15 Amp.

 

So I have built a new milling table system and tested it with fully closed loop BLDC Motors and stepper motors. Both systems worked as expected once tuned and programmed.

 

One issue i seem to have with the stepper motor configuration is if I do a reset and save with $$$***, save.

 

Then download my fully working project the motors won't move. I just see a following error develop.

 

If I open the System -> Motors -> 1-5 one at a time and change one thing, for example change my input Voltage by 1 V, and step through each configuration step for the motor saving it and commissioning. Then I download my working configuration everything works fine?

 

I even tried copying the entire systemsetup.cfg to a Global include to force all the parameters back to my working config and it still won't move the motors until I step back through the Motor Setup even though they all show Green and good to go.

 

What variable is getting set to enable the direct micro-stepping that i can't seem to set from a text configuration?

 

Shouldn't I in practice be able to forgo all the GUI system setup options and just pipe in a hard-coded system configuration as a Global include Starting out with

 

sys.WpKey=$AAAAAAAA

 

then save and Comment out the contents of that file and continue with the rest of my programming. Then once everything is tuned and working perfect I can create a new master configuration file from the systemsetup.cfg and make that my fail-safe to reload in the even something gets horribly out of wack?

 

Thanks

John.

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...