Jump to content
OMRON Forums

Homing and phasing


Sam01
 Share

Recommended Posts

Hello everyone,

 

Please can some educate me on how to fix Fatal following Error and warning following Error?

 

I always get Fatal following Error and Warning following Error on motor 3 whenever I attempt homing and phasing.

 

I have three motors and motors 1 and 2 usually complete homing and phasing except motor 3.

 

Please can someone tell me how I can fix it?

 

Thank you.

 

 

Sam.

phasingerror.thumb.PNG.e67af81fcf4e33716692217bffdafd8e.PNG

Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

What is the background of this system? Was it previously working reliably? Did something change?

 

Following error is how much difference there is between desired and encoder position. Your PMAC has settings for fatal and warning following error limits (IXX11 and IXX12). If the fatal following error limit is exceeded the motor will be killed. The warning following error limit is only used for a status bit. (It can be used for hard stop homing.)

 

Are there any circumstances where you can jog motor 3? It may be failing to phase due to bad settings or physically hitting an obstacle. If the motor does not phase successfully it will not be controllable. I would take a look at IXX73, IXX74, and IXX80.

 

You may find the training presentation here useful.

).pdfhttp://forums.deltatau.com/filedepot/download.php?f=Turbo%20PMAC/Training%20Documents/Turbo%20PMAC%20Training/Training%20Presentation/Turbo%20PMAC%20Training%20(Sept%202015 [FILE REMOVED]

Link to comment
Share on other sites

A couple of other things.

You might try manual phasing in order to determine if poor phasing is the problem.

Faulty feedback is another thing that can cause following error. Typically, an encoder count error will be a clue if there is a problem with the feedback signal. If the "Suggested M-Variable Definitions" have been downloaded as shown in the Turbo Software Reference manual, M318 will be set =1 if an error was detected.

What type of Turbo PMAC is this?

Link to comment
Share on other sites

Thank you so much Gregs and Eric.

 

The problem has been solved.

 

I cleared the settings using the $$$*** command and I uploaded the setup again.

 

When I did that it worked fine as expected and all the phasing and home of the motors were completed without errors.

 

Thank you.

 

meanwhile, my PMAc is a TURBO2, X4

 

 

Sam

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...