Jump to content
OMRON Forums

Using a MicroHAWK ID-20 with Raspberry Pi3


Recommended Posts

Summary

 
Tests were run using an ID-20 and a Raspberry Pi3 SBC running Raspbian to determine to what extent the ID-20 is compatible with this hardware / software combination. It was found that, if the ID-20 has a static IP address, then WebLink and Telnet can both be used to talk to the reader.
However, the virtual com port cannot be accessed from Linux

Initial Network Configuration

 
1.     Starting with a clean Raspbian operating system. Set up your wifi or wired network for internet access if required.
 
2.     Go to network icon in top-right of menu bar and right-click on it.
User-added image
 
3.        You'll see two network adapters listed if you click on the interface drop-down – wlan0 and eth0
User-added image
 
 
Now plug in your ID-20 (configured for static IP address)
ifconfig from terminal will show additional adaptor eth1.
 
There is no graphical tool for configuration ethernet interfaces. Instead, you have to edit
/etc/network/interfaces. You can do this as follows:
 
  1. Open a terminal window
  2. Navigate to the correct directory ( cd /etc/network )
  3. make a copy of the interfaces file ( sudo cp interfaces oldinterfaces ) Open interfaces file with nano ( sudo nano interfaces )
  4. scroll down to end of file and type in the following

allow-hotplug eth1
iface eth1 inet static

address 192.168.188.1
netmask 255.255.255.248
gateway 0.0.0.0
 
  1. Once you've typed that in, Control-O and Enter to save and Control-X to exit.


 To check that it worked you can type in “more interfaces” to see the contents of the interfaces file.
User-added image 

Now unplug the camera and plug it in again. You can see the network settings by using the ifconfig command in the terminal window.
User-added image
 
At this point you can open Chromium (web browser) and navigate to the address of your camera to bring up WebLink just as you can on a Windows PC.
 

Testing with WebLink through browser.

 
WebLink works exactly the same on Linux as it does on Windows.
 

Testing with Telnet from command line

 
Note that telnet is not installed by default on Raspbian. sudo apt-get install telnet to do this. Problems were encountred accessing mirror servers for packages, unplugging the MicroHAWK from Raspberry Pi appeared to help solve these issues. This suggests that the software was trying to use the wrong network adapter to access the servers.
Once telnet was installed it worked just as it does on Windows.
User-added image

 

Remote triggering from another PC.

 
Set up SSH on Raspberry Pi. You enable this by going to the Pi menu - Preferences - Raspberry Pi Configuration - Interfaces. You should probably change the default password for security here and the Pi will nag you if you don't.
Connect to Raspberry Pi SSH from PC using program like PuTTY. Port number for SSH is 22. You can then enter commands just as you would if you were running on the Pi directly.
 
 

Adding Additional Cameras

 
Adding additional cameras requires adding additional information to the /etc/network/interfaces file. Here's a screenshot showing two ID-20 MicroHAWK cameras connected to Raspberry Pi.
User-added image

 
Tests have not yet been run to ensure that multiple cameras enumerate in the same order every time the Pi is powered up.
 

Using Dynamic IP Addressing

 
At this point in time it has not been proved possible to connect Raspbian to an ID-20 set to DHCP. Tests were run with both static and DHCP (APIPA) on the Pi.
 
 

Using VCOM to communicate with ID-20

 
VCOM does not work on the Pi3 / Raspbian (or any other version of Linux tested). The cause for this is believed to be the lack of support for composite USB devices in Linux.
 
Looking on the web, it appears that there are a number of devices that have the same problem on Linux and that these have been hard-coded into one of the linux driver files (/drivers/usb/class/cdc-acm.c). This is unlikely to happen for the MicroHAWK.
Apparently the workaround is to mark the device (in the file above) with "NO_UNION_NORMAL" which means that the device has no union descriptor.
 

Appendix A : Configuring the ID-20 to use a static IP address

 
The ID-20 needs to be configured to use a static IP address before using it with Raspbian. The easiest way to do this is to connect the reader to a PC and then open a web browser to connect using WebLink.
 
Once you have WebLink open (default address is 192.168.188.2), go to the gear wheel icon in the upper right, click on it and then click on the Advanced icon.
User-added image

 
This will open the configuration pages as shown below. Select Communications.
User-added image

Click on DHCP and change it to Static. If the camera address also needs changing then do that here too.
User-added image
 
Close the Advanced Settings box and save the camera settings to flash memory using the icon in the upper right indicating a reader on top of a floppy disk.
User-added image
 
The ID-20 is now ready to connect to Linux.

Operating System

Any

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...