Jump to content
OMRON Forums

Can't create new variables. I also get ProjectLoadErr when trying to add a new .pmc


Pyroelk
 Share

Recommended Posts

Feel like I'm missing something in my IDE. 

Using PowerPMAC IDE 4.3.0.107 with an arm,LS1021A Firmware 2.6.0.0

When adding new variables, they do not seem to populate. Hovering over the tags shows this:

Type : Global

Name : homingSlvEpoxyChanger

Value : stdin:9:2: error #20: ILLEGAL CMD: homingSlvEpoxyChanger

 

Also tried to add a new .pmc and get ProjectLoadErr. The project will build but will not download. Output shows this:

Error: Opening File: "/var/ftp/usrflash/Project/PMAC Script Language/Libraries/homeSlvEpoxyChanger.pmc"
 

 

I've tried just building, build and download, saving, $$$. Feel like something is missing in the complier, but im stuck here.

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

This is an existing project that I am just beginning to edit. I can make code changes as long as I use the existing routines and variables. 

homingSlvEpoxyChanger is a new global variable I just added. It is not used for anything else. It doesn't give me any build and download issues, just does not have a valid value. 

homeSlvEpoxyChanger.pmc is a new subroutine I just created. I can edit it, and build the program, but it will throw the error I listed above when attempting a download.

I cannot complete a build and download unless I delete the freshly made homeSlvEpoxyChanger.pmc 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...