Jump to content
OMRON Forums

Option to use new PDO mapping name has been set to false


Recommended Posts

I've recently upgraded to IDE 4, and have been unable to load my project solution files, despite accepting the file upgrade.

The errors I've received are: 

Error - value cannot be null, parameter name: url

The option to use new PDO mapping name has been set to false because this project may have a program that uses existing name format. Please change the option on the property of the project to use the new format.

When I try to go to the property settings of the project within the IDE, it says there are no properties.

Any idea what this is trying to have me do and how to work around it?

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

  • 1 month later...

I have this error message many times. We have several project on GitLab, with many branches. After almost every merge operation, the solution cannot be open anymore with this same error message: "Value cannot be null. Parameter name: url." This message is terrible, I have no idea what is going on or what I did wrong. It doesn't seem to come from the .ppproj, I compared them before and after. I guess this is some missing files, but there arn't enough details in the message.

Do you know what I should be looking for ? 

Link to comment
Share on other sites

From your description, I might suspect you are modifying the project outside the IDE. This could cause project corruption, as the project files maintained by the IDE would not be properly updated. There is no documentation on manually editing theses files other than what the PDK’s “Build and Download” functions would provide. Note that the current version of the PDK does not have support for many of the newer IDE features (systemsetup.cfg and others) since the inception of IDE vs 4.5.


I will put a query in with the software developers on this issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...