Jump to content
OMRON Forums

modbus io


Ashish Navale
 Share

Recommended Posts

  • Replies 11
  • Created
  • Last Reply

Top Posters In This Topic

You can download the Modbus training slides here: http://forums.deltatau.com/filedepot/download.php?f=Turbo%20PMAC/Training%20Documents/Modbus/Modbus%20TCP%20training.ppt [FILE REMOVED]

 

More Modbus related documents can be found in FileDepot>Turbo PMAC>Training Documents>Modbus

Link to comment
Share on other sites

Thank you sir,

 

i did all setting according to modbus setup configuration....

i am using coupler + 16Do module +end module

As per the slide do will read at address I67+$95

Means my io will read on

e.g i67=$10700

then DO address will start from I67+ $95=$x:10795

Link to comment
Share on other sites

  • 2 weeks later...

Thank you Sir ,

 

But i did all possible settings but i can,t proceed i am using wago 750-352 coupler+750-1504 16 DO module+ end module

modbus setting are as below

i67=$10700

Addr off=112

active socket 1

geobrick ip address 192.6.94.5

wago module ip: 192.6.94.17

fc=5

modbuf ref=0

pmac ref=0

count=16

update commd 0

update pmac

in modbus setup.

in pmac for forcing coil from pmac

i assign addr to m variable as below

m150->x:$10780,0,1

 

and from terminal window i gave value

m150=0/1

 

but coil are not activate.....

i tried checked for next 10780-10980

but coil not activate.......

 

is their another setting or i have write any program in geobrick

 

please guide me .......

Link to comment
Share on other sites

Thank you sir,

 

previously also tried fc=5 with count=0,but didnt work

i tried with both cmd

fc=5

mod ref =0

pmac ref=0

count=1.................for single coil

m6070->x:$10780,0,1 .....for coil on/off

 

 

fc=15

mod ref =0

pmac ref=0

count=16.................for multiple coil

m6070->x:$10780,0,15

 

let me try once again......

 

thank you.

Link to comment
Share on other sites

Thank you sir,

 

i read all notes and tried to setup connection between PMAC and PC with modbus slave software for this i used standard ethernet cable .

i having UMAC controller + PC

UMAC and PC comm on Ethernet cable

According to excel sheet (PMAC modbus client master..tab)

 

i did setting accordingly

 

but modbus slave soft gives error...cannot assign requested address.... error 10049

Link to comment
Share on other sites

Good Idea to use Modbus Slave software.

 

The error your reported is common error reported by windows. You can google this and get below:

 

http://www.pscs.co.uk/helpdesk/vpop3help/vpop3/socket_error_10049.htm

 

It means that your PC can't see that IP address.

Likely:

1. You have put in the wrong IP address for the PMAC into mobus slave software.

2. Your computer is on a different sub-net from the PMAC.

 

Tell me what the IP Address for your PMAC is ?

What is IP address of your PC it is talking to ?

- they must have the first 3 values matching

- example: both must be same like this 192.168.0.xxx

- the xxx must be different, but the first 3 values must be same

 

Also to test... go to a Dos Prompt on your PC and use the Ping command. Example if you PMAC is at IP 192.168.0.200 then go to Dos prompt and type "ping 192.168.0.200" and see if it suceeds, if it does not then either you are not connected or the IP address is wrong, or the IP's are not on same subnet (first 3 values the same).

Link to comment
Share on other sites

Thank you sir ,

i got solution for this but i saw it not update values every time i have to assign value to register

e.g i did set up for write 4 coils

timer =1

fc=16

count=4

update pmac.....

reg 1 m1000->x:$10780,0,16

reg 2 m1001->y:$10780,0,16

reg 3 m1002->x:$10781,0,16

reg 4 m1003->y:$10781,0,16

 

while updating value to this register every time i have to assign values to reg then save and $$$ cmd to see this values in MODBUS Slave software .......

 

any way i have to read modbus on PC and its solve means i am confident on our device sending correct values to modbus slave software.

 

once again Thank you to all.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...