Jump to content
OMRON Forums

NC32-v2.36 MDI/Buffer Operation


Eyewonder
 Share

Recommended Posts

I have a small lathe set up, and am able to to jog, home axes using Adv600 control panel, but do not fully understand how the MDI & buffer operate.

 

I first home the X & Z axes.

 

I enter 'S400 M03' (on separate lines) into the edit window, click the 'Write to Buffer' command button, then push the 'Cycle Start' button. Spindle rotates as expected.

 

If I then enter 'Z1.5' (just some move to verify operation) into the edit window, as soon as I click the 'Write to Buffer' command button, it kills the spindle rotation. Pushing the 'Cycle Start' button causes the Z to move, as expected.

 

Is this 'normal' operation for this software? BTW, this was using the v2.36 software, NOT the v2.36(1) 4 program changes.

 

I enabled buffer logging and got these results:

 

Into Auto or Mdi Mode Sun Aug 17 20:45:20 2014

 

 

input -> S400

output -> BSTARTM167=1 F5.0 CCR 0.000000 M158=0G49.0H0.000000X0.000000Z0.000000DWE0NRM K-1 G17.0

G0.0ABS G90.1G98.0G20.0G49.0G97.0G54.0X0.000000Z0.000000DWE0S400M26==400DWE0BSTOP

 

input -> M03

output -> BSTARTM167=2 M3.000DWELL4STOPBSTOP

 

input -> G00 Z1.5

output -> BSTARTM165==1M167=0 G0.0Z1.5 DWELL4STOPBSTOP

Shutting Down Logging Sun Aug 17 20:46:51 2014

 

 

 

Cheers,

Steve

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...