Jump to content
OMRON Forums

Problems implementing HOME on Geo Brick LV


jwlamb
 Share

Recommended Posts

I am having a lot of issues trying to implement a HOME move for a Geo Brick LV. I have a motor with an incremental encoder, and limit switches using Hall-effect sensors. The goal is to use the minus limit as the home position and define a zero position approximately mid-way between the plus and minus limits (this will be a number entered manually). The motor is Motor 3.

 

I am trying to follow the Turbo PMAC User Manual (particularly p. 228), along with the Geo Brick User Manual and the Turbo SRM.

 

I324=$800001 ; For Geo Brick (PMAC2, and Amp Fault)

I325=$078010 ; Register for channel 3

I7032=2 ; Capture on flag (NOTE: Error in manual -- digits 2&3 swapped)

I7032=2 ; Use minus limit (NOTE: Error in manual -- digits 2&3 swapped)

 

The HOME3 instruction is in a motion program.

 

As written, the mechanism goes to the minus limit, turns around, and keeps going at a high speed in the plus direction, passing the limit switch. According to the manual, it should stop on the minus limit (Note: this happens whether or not the limits are disabled with Bit 17 in I324 ($800001 -> $820001 -> HOME -> $800001).

 

The encoder position readings in the PEWIN32PRO2 Position window do not change at all, except when the minus limit is acquired, and then it has some large positive value. That stays fixed when it heads off in the plus direction.

 

Any suggestions would be most welcome.

 

The value of the offset (I326 has no effect).

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Additional info: The Turbo PMAC User Manual (p. 228) states

"On PMAC-style servo channels, the polarity of the limit switches is the opposite of

what many people would expect. The -LIMn input should be connected to the

limit switch at the positive end of travel; the +LIMn input should be connected to

the limit switch at the negative end of travel"

 

That appears to be incorrect... I did try swapping the limits, but that did not help. Also the motor would drive out of the limit, but not back in again, indicating that the swapped configuration was wrong :-(

 

I have the software limits disabled.

Link to comment
Share on other sites

That statement is missing some details discussing limit switch geometry: does the switch move or does the dog move and how they are placed. In any event this will probably be removed in the next release to avoid confusion.

 

I believe you may not be setting the correct variable to select the OT minus switch. You’re showing I7032 it should be I7033.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...