Jump to content
OMRON Forums

Error: Opening pp_hardware.sym file


motionusa
 Share

Recommended Posts

We just tried to build and download changes to a project on a 2 axis Power UMAC and received a message on the output saying: "Error: Opening /var/ftp/usrflash/Database/pp_hardware.sym File". We have been downloading changes to this project regularly for weeks without ever seeing this error. We have not made significant changes since our last build and download. We have tried power cycling the PMAC and restoring it to factory defaults. We have not had any luck. Do you have any idea what could be causing this or how to fix it?
Link to comment
Share on other sites

  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Hi,

 

Do you get the same error with a New, blank project?

 

Also, did you change firmware or IDE versions?

 

Charles,

 

We get the same error with a New, blank project.

 

We did not change firmware or IDE versions. Nothing significant (only one line of code) was changed when we tried to build and download and started getting this error.

 

The IDE version is 2.0.3.40 dated 4/21/2015.

The firmware version is 2.0.2.14

Link to comment
Share on other sites

Please try issuing

 

$$$***

SAVE

$$$

 

and then download again.

 

I have also asked the software engineer responsible for the Project system of the IDE to take a look at your issue.

 

We've tried that. No change.

 

FYI - When we load in a new, blank project, we get the following errors on the output:

 

uploading pp_save.cfg file from the Power Pmac.

Error: Could not upload the pp_save.cfg file from the Power Pmac.

uploading pp_custom_save.cfg file from the Power Pmac.

Error: Could not upload the pp_custom_save.cfg file from the Power Pmac.

uploading pp_error.log file from the Power Pmac.

Error: Could not upload the pp_error.log file from the Power Pmac.

uploading pp_proj.log file from the Power Pmac.

Error: Could not upload the pp_proj.log file from the Power Pmac.

uploading pp_error_hist.log file from the Power Pmac.

Error: Could not upload the pp_error_hist.log file from the Power Pmac.

 

On the terminal when we issue a save command, we get:

 

Save Did Not Complete. Check Sys.WDTFault & LOG\pp_error_hist.log file

Link to comment
Share on other sites

I had a similar problem to this just the other day after a routine power down and power up condition. I was receiving the error where it could not find the pp_hardware.sym file. Upon further examination I noticed that in the /var/ftp/usrflash directory, the only directory left was 'Project'. Both 'Database' and 'Temp' had disappeared. In my case, I just recreated the directories and copied in the directory contents from a like running PPMAC, and all was fine after that. It was the first time I had experienced this problem.
Link to comment
Share on other sites

  • 2 years later...

I had a similar problem to this just the other day after a routine power down and power up condition. I was receiving the error where it could not find the pp_hardware.sym file. Upon further examination I noticed that in the /var/ftp/usrflash directory, the only directory left was 'Project'. Both 'Database' and 'Temp' had disappeared. In my case, I just recreated the directories and copied in the directory contents from a like running PPMAC, and all was fine after that. It was the first time I had experienced this problem.

 

Hello I am having the same issue, I recreated the directories but it still complains about missing files in the Configuration folder during the upload , and the save command although it says save completed does not save anything .

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...