Jump to content
OMRON Forums

465CPU eth0 port auto-negotiate


kmonroe023
 Share

Recommended Posts

We recently received a couple of PMACs with the 465CPU.

 

The version we have has two Ethernet ports. The first port (eth0) only seems to connect to other devices that are running at 1Gbs. It appears that auto-negotiate is not working on eth0.

 

The other port, eth1, connects to both 1G and 100Mbs and auto-negotiates the network speed as required.

 

If I run "mii-tool" from the OS prompt, eth0 just reports "bad address" (see below).

 

We have two 465 Pmacs, and they both exhibit this behavior. Is this by design?

 

mii-tool output:

 

192.6.94.200:/opt/ppmac# mii-tool -v

SIOCGMIIPHY on 'eth0' failed: Bad address

eth1: negotiated 100baseTx-FD flow-control, link ok

product info: vendor 00:07:32, model 17 rev 4

basic mode: autonegotiation enabled

basic status: autonegotiation complete, link ok

capabilities: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

link partner: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

root@192.168.0.200

192.6.94.200:/opt/ppmac#

 

 

Thanks,

kmonroe

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...