Jump to content
OMRON Forums

New release 2.1.0.107 crashes while motor tuning


kandauru
 Share

Recommended Posts

Hi,

I was trying to tune motors in new release of Power PMAC Suite, but when I pressed "Do a Step Move" in position loop interactive tuning window, the software crashed

and restarted itself. The small note: the motors are in gantry - follower mode.

Please, advise.

Link to comment
Share on other sites

  • Replies 18
  • Created
  • Last Reply

Top Posters In This Topic

I just tried a simple test of gantry follower with motors 2 following 1:

Motor[2].ServoCtrl = 8

Motor[2].CmdMotor = 1

 

I was able to step motor 1 without issue. Can you provide details on your motor setup and firmware version? This may be better handled a technical support issue contact us at support@deltatau.com with the details.

Link to comment
Share on other sites

  • 2 weeks later...

I am having the same issue where the IDE (2.1.0.107) crashes when I attempt to do a open step response.

 

Primary option: I know that i can do an update to my firmware to fix this, however right now I'm stuck at 1.5.8 since when I upgrade any higher, my code doesn't run correctly at it did before. So I always had to revert back

 

Backup option: I believe that I was able to do the tuning fine with my old IDE (version 1.6.0.109) however, when I go to download filedepot to download it, the file is only about 9 mb in size. Where is it supposed to be ~700 mb in size. Is there a way I can get access to this old version of the IDE?

 

thanks,

windell

Link to comment
Share on other sites

Hello Steve,

 

I have found the problem with homing procedure (look at line 46 in my attached file sub_home.pmc):

 

there is an expression:

 

gatenumber = int((inMtrNr-1)/4)

 

in case when inMtrNr = 4 or 6, the result is wrong - 1 and 2 accordingly (should be 0 and 1).

Please, check it.

Link to comment
Share on other sites

I've attempted to start the tuning process with the old IDE (1.6.9) and I'm getting the same behavior that the IDE crashes when I try to do a step. I'm in the process of upgrading my firmware, but there are some unexpected hurdles that I need to leap over before that happens flawlessly.

 

Any suggestions I should try? I've tried tuning using the newest IDE and 1.6.9 and both do the same thing.

Link to comment
Share on other sites

  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...