Jump to content
OMRON Forums

Motor setup : Output Signal Type


kandauru
 Share

Recommended Posts

Hi,

 

I am working with Power Brick Controller and Power PMAC IDE 2.1.0.107 (with firmware 2.1.1.3 ). I am trying to setup motor using System Setup tool. When I reach step 4. Hardware Interface, the software does not accept entered data(see attachment).

I have put my attention on Output Signal Type field, it is not described in the last manual for Power PMAC IDE. So, maybe it also does not exist in your internal data structure where the software trays to put the entered data to?

What is the field of Motor[x] structure is it?

Please, advise.

Link to comment
Share on other sites

  • Replies 17
  • Created
  • Last Reply

Top Posters In This Topic

Please give the serial number of the unit.

 

Also show what the hardware interface node shows about the hardware.

 

You should have pull-down options here but the messages below say there is a hardware problem that the interface required does not match the hardware existing.

 

Also try changing the amplifier advanced interface mode to false

Link to comment
Share on other sites

Attached is same hard disk, but it is connected to UMAC rack now.

All fields are coming filled with data automatically in Hardware node and Accept button

works. So, it looks like the problem is in Power Brick Controller. Please, advise.

OutputSignalTypeUMAC.thumb.JPG.9dfd44dddafc83f066de0ac3530215b5.JPG

Link to comment
Share on other sites

This is the hardware options you have.

1 C000DADE PBC8-G21-000-AA00000 100 POWER BRICK CONTROLLER,8 AXIS, 800MHZ, 2GB DDR2, 1GB FLASH, AXES 1-8 TRUE 16BIT DAC, 8 ENCODER & FLAG INPUTS, 48/24 DIGITAL I/O

.2 C000DXH0 38A-603860-10X 106B CHAN 1-8, 16 BIT TRUE-DAC WITH I/O

.2 P0179324 3-4020G0-2100-000000 108B POWER UMAC CPU ASSEMBLY CONFIGURATION WITH

..3 C000DNFE 3-402200-0100-000000 105B POWER UMAC 1 GB BUILT-IN FLASH STORAGE FOR USER CONFIGURATION

..3 C000DNK3 3-4020G0-0000-000000 108B POWER UMAC CPU ONLY CONFIGURATION WITH

..3 302-604020-OPT OPT-2, 2GB RAM, DDR2 MEMORY MODULE

.2 C000DBU7 300-604034-10X 101 POWERPMAC CPU TO POWERBRICK INTERFACE BOARD BACKPLANE

.2 C000DCSS 306-604030-10X 106E GEO POWER BRICK INTERFACE WITH 8 AXIS

 

I want to see what the setup program sees as the hardware. So you need to look at the hardware nodes and see what was detected by the setup program and if it matches the true hardware you have.

Link to comment
Share on other sites

This was the unit that needed the EEPROM reprogrammed. We reviewed the programming and what we can see it is OK. I think the IDE System Setup program is not working properly for the Power Brick Controller. Steve Milici in DTCA will need to verify this, but to day is a holiday in USA.

 

To get around this you can do the setup manually. You can use the same Gate3[] and Gate3{].Chan[] settings as you have in the UMAC. The gates and the interfaces are the same. You will just need to use the Gate3[0] and Gate3[1] structures and test the feedback and outputs by hand.

 

The Motor[] structures should also be very similar to the UMAC.

 

Of course the setup program makes this easier but at the moment it seems the manual way is the only choice.

 

I will e-mail Steve Milici to make sure he picks up this thread when he is back from Holiday.

Link to comment
Share on other sites

Hi,

 

I tried to do that manually, but the problem is still there - "Do A Step Move" is not working.

I am using same motor setup file you built when you were here.

So, my question is - if I can take project from UMAC and re-compile it on Power Brick controller?

Is it compatible? Of course I have replaced Acc24E3 with Gate3.

Once again, I am working with same system (all motors are same in both cases, just UMAC rack replaced with PowerBrick controller).

 

Thank you in advance.

4-encoder conversion table.pmh

5-motor setup.pmh

Link to comment
Share on other sites

The system configurations are compatible as written before. Of course in such situations you must go through each piece, Feedback, Output, Status and discover what fault is creating the problem. You can not expect to just go to a step move and press a button, you must manually go through the steps that the setup program goes through in the configuration process and testing process and see what is going wrong. You know these steps since you have done the same work on the UMAC.

 

You might want to look in the PowerBrickController manual about the Abort input and the structure Sys.pAbortAll since this is a difference between UMAC and Controller that you might have missed.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...