Jump to content
OMRON Forums

Difficult to issue "ECAT[0].Enable=1"


lovu
 Share

Recommended Posts

Hello there,

 

My CK3E firmware is 2.3.2.5.

I found it difficult to issue "ECAT[0].Enable=1" in terminal. I have downloaded the ENI file and setup motors and once successfully command motors to move. But if I issue "ECAT[0].Enable=0" and "$$$" then "ECAT[0].Enable=1", no motor movement can be found from Position window. Even "ecat reset" and "ecat slaves" cause no responce.

I'm sure ethercat network configuration is already downloaded.

The only way that make sense is to reboot CK3E and all slaves. All occurs again if CK3E is reseted..

 

Why?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

after you load the new firmware you must issue $$$*** then save the $$$. Then you must redownload the project and all motor settings. Then open system setup and redownload the .eni file. Again do a save and power cycle the slaves and the CK3E
Link to comment
Share on other sites

after you load the new firmware you must issue $$$*** then save the $$$. Then you must redownload the project and all motor settings. Then open system setup and redownload the .eni file. Again do a save and power cycle the slaves and the CK3E

 

By saying "Again do a save and power cycle the slaves and the CK3E", you mean a reboot operation for CK3E and all slaves MUST be done after the save operation of downloading ENI file ?

 

I will have a try.

 

Thank you so much.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...