Jump to content
OMRON Forums

Motor #1 disable Motor #2,#3 and #4


CVillaleiva
 Share

Recommended Posts

Hi, i have a CS with four motor configurated with the same characteristics.

 

this motors are conected to the JMACH 1 of my Power Pmac Clipper Controller. I have the fault motors input floating and only connected the DACs output and Encoders Input to the controller.

 

If i move each motor in the jog mode, all motor works find, but when i try enable all motor using #xj/ command to enable the CS the motor #1 send to fault other motors.

 

for example

 

#2j/ -> motor[2].fault=0

#3j/ -> motor[3].fault=0

#4j/ -> motor[4].fault=0

#1j/ -> motor[1].fault=0, motor[2].fault=1, motor[3].fault=1, motor[4].fault=1

 

So i never can enable the CS.

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Hi, i have a CS with four motor configurated with the same characteristics.

 

this motors are conected to the JMACH 1 of my Power Pmac Clipper Controller. I have the fault motors input floating and only connected the DACs output and Encoders Input to the controller.

 

If i move each motor in the jog mode, all motor works find, but when i try enable all motor using #xj/ command to enable the CS the motor #1 send to fault other motors.

 

for example

 

#2j/ -> motor[2].fault=0

#3j/ -> motor[3].fault=0

#4j/ -> motor[4].fault=0

#1j/ -> motor[1].fault=0, motor[2].fault=1, motor[3].fault=1, motor[4].fault=1

 

So i never can enable the CS.

 

Hi,

 

Since you are not using the amplifier fault bits, try disabling them:

 

Motor[1].pAmpFault = 0

Motor[2].pAmpFault = 0

Motor[3].pAmpFault = 0

Motor[4].pAmpFault = 0

 

-Chris

Link to comment
Share on other sites

Hi, i have a CS with four motor configurated with the same characteristics.

 

this motors are conected to the JMACH 1 of my Power Pmac Clipper Controller. I have the fault motors input floating and only connected the DACs output and Encoders Input to the controller.

 

If i move each motor in the jog mode, all motor works find, but when i try enable all motor using #xj/ command to enable the CS the motor #1 send to fault other motors.

 

for example

 

#2j/ -> motor[2].fault=0

#3j/ -> motor[3].fault=0

#4j/ -> motor[4].fault=0

#1j/ -> motor[1].fault=0, motor[2].fault=1, motor[3].fault=1, motor[4].fault=1

 

So i never can enable the CS.

 

Hi,

 

Since you are not using the amplifier fault bits, try disabling them:

 

Motor[1].pAmpFault = 0

Motor[2].pAmpFault = 0

Motor[3].pAmpFault = 0

Motor[4].pAmpFault = 0

 

-Chris

 

Thanks Chris, now i can enable all motor togethers.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...