Jump to content
OMRON Forums

Unpredictable / not traceable run-time error w/ Lookahead active


sutty
 Share

Recommended Posts

Hi!

 

We are running a PPMAC ARM V2.3.2.5 on Phase/Servo/RTI 32/16/2 kHz, 2x3 cascaded motors (6 motors)

 

Running the application w/o Lookahead doesn't cause any problems.

But with Lookahead active (10ms Segmentation, 130 Segments) once in a while (every several minutes up to every several hours) run-time error occurs. Unfortunately, Coord[x].Ldata.Status always tells a 1 after such run-time error - it does not give any useful information.

 

What is very confusing to us is that a few milliseconds before run-time error occurs Sys.RtIntTime peaks for the duration of only 1/16 of a millisecond!!

Another characteristic is that as long Sys.RtIntTime stays below 750 us run-time error does not show up at all.

Augmenting Sys.PreCalc does not help.

Removing RtiCplc does not help neither.

At last whenever a run-time error happens it almost always shows this kind of pattern.

 

Today we started testings with V2.4.1.2 - results will follow.

 

Questions:

1. Why would Sys.RtIntTime peak for less than 70us?!

2. Any suggestions which PPMAC-Variables to trace to get more useful data?

 

Best Regards,

Anton

ppmac_arm_v2.3.2.5_run-time_error_after_RtIntTime_peaks.thumb.jpg.b409a93e77afb89e52814de0e6118c6f.jpg

ppmac_arm_v2.3.2.5_run-time_error_after_RtIntTime_peaks_detail.thumb.jpg.c29bd2eaa833529d859611a8797791b5.jpg

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...