Jump to content
OMRON Forums

CK3E EtherCAT Acontis - howto accomplish bus shift mode


sutty
 Share

Recommended Posts

Hi!

I run CK3E (2.5.0.3) with 2 Omron 1S-drives (Rev 10001). In master shift mode it's fine.

 

Howto accomplish bus shift mode?!

Why still do I have to set "ECAT[0].DCRefMaster=1" after loading Mapping to PowerPMAC?!

 

What I do (without success)

1. set Clock adjustment to bus shift

2. Click "Load Mapping to PowerPMAC"

3. Set using terminal "ECAT[0].DCRefMaster=1" (where point 2 let it at 0)

4. Clicke "Activate EtherCAT"

 

Why wihtout success:

The drives would run in CSP, but reading the slaves register 0x92C would give for the first slave steadily 0 (!) and for the second slave <>0. Both should deliver <>0 values in case of bus shift mode.

 

Regards, Anton

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Thanks Steve!

 

I upgraded using IDE V4.3.2.19 from V2.5.0.3 to V2.5.4.0 - and lost gpascii and other stuff - no connection to ppmac anymore. Serially I can still conect. /opt/ppmac only shows usrflash and usrflash.x directories, nothing else anymore.

 

So how to successfully upgrade from V2.5.0.3 to V2.5.4.0 resp reinstall the lost directories?!

Link to comment
Share on other sites

I could recover and successfully install V2.5.4.0, thanks to great support from Lucien / ODT Switzerland.

Looks like the device-tree "ls1021a-twr-ck3m.dtb" wasn't updated at all.

 

Anyhow, now bus shift mode seems to work fine.

Thanks!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...