Jump to content
OMRON Forums

Handwheel-Position Following mode


zhangzheng2277
 Share

Recommended Posts

Hello,

 

I'm currently using the Position-Following mode to implement a Jog/Increment Handwheel. I'm enabling following in normal mode (Motor[x].MasterCtrl = 1). I'm running into one issues with its behavior.

The handwheel control axis normal at 0.1mm and 1mm per revolution, but the mechanism will make abnormal sound at 10mm per revolution, and it is normal at other modes of control.The handwheel has 400 pulses per turn,The controller CK3E,Is there any parameter that can improve this situation?

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

This is probably a result of “noise” in the master position being “amplified” by Motor[x].MasterPosSf. You can use the “Motor[x].SlewMasterPosSf” to “filter out” noise. For details see the description of this parameter in the “Power PMAC Software Reference Manual” starting on page 521. Also see the section “Processing the Master Position Signal” in the “Power PMAC User’s Manual” for other suggestions, starting on page 769 (770 electronic).
Link to comment
Share on other sites

This is probably a result of “noise” in the master position being “amplified” by Motor[x].MasterPosSf. You can use the “Motor[x].SlewMasterPosSf” to “filter out” noise. For details see the description of this parameter in the “Power PMAC Software Reference Manual” starting on page 521. Also see the section “Processing the Master Position Signal” in the “Power PMAC User’s Manual” for other suggestions, starting on page 769 (770 electronic).

 

Thanks for your reply. You're right.

I used the "Motor[x].MasterMaxSpeed" and "Motor[x].MasterMaxAccel" to basically solve the problem.

Link to comment
Share on other sites

The feedforward servo gains on the follower motor can end up trying to predict the future behavior of the master encoder, leading to noise. You might try these settings for the follower motor:

Motor[x].Servo.Kaff=0
Motor[x].Servo.Kvff=Motor[x].Servo.Kvfb
Motor[x].Servo.Kviff=Motor[x].Servo.Kvifb

Link to comment
Share on other sites

The feedforward servo gains on the follower motor can end up trying to predict the future behavior of the master encoder, leading to noise. You might try these settings for the follower motor:

Motor[x].Servo.Kaff=0
Motor[x].Servo.Kvff=Motor[x].Servo.Kvfb
Motor[x].Servo.Kviff=Motor[x].Servo.Kvifb

 

Thanks Eric,I'll try your method.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...