Jump to content
OMRON Forums

Ethercat 16 bit integer PDO


ulhasfegade
 Share

Recommended Posts

We are using Kollmorgen drive and configured PDO 6077 (Actual torque). This PDO is 16 bit integer. This data is signed integer data in the drive. However in the controller we are getting this as 16 bit unsigned integer. Can anyone tell me how to map this data in Ethercat so that I get directly signed integer?
Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

I ran into similar issue with Yaskawa drives.

 

I fixed it by opening up the Yaskawa ESI file matching the drive and then changing the data-type on the torque entry from UINT to INT

and then re-importing the updated ESI back into PowerPMAC IDE.

 

After that, the data was mapped correctly into the PowerPMAC as a signed integer..

Link to comment
Share on other sites

  • 9 months later...

Just wondering if you found a solution to this. I'm seeing the same thing with PDO 0x6077 Actual Torque.

Also I'm having issues with scaling the Motor[1].pDac to Target Torque (0x6071) which is a 16 bit number. Just wondering if you found a solution. 

 

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...