Jump to content
OMRON Forums

getting simple NC file running


tkb11
 Share

Recommended Posts

I have a simple 3 line NC file. It has nothing but 'G00' on the first line. When I run it nothing happens. I suspect I need to do something to make G-Codes, even the default, work? Help?

 

This is version 1.7r from 8/20/18. I've been successfully running programs from IDE version 4.4.2.3 but need to get NC16 working. The position display works. I can jog successfully and home works.

 

The machine is very simple, a diamond turning machine with only two axis but uses interferometers for position (accurate to 1,270,000 counts per inch)

 

TIA

Link to comment
Share on other sites

  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

This is the entire program

 

G00

X.1 F.1

M30

 

IDE (status dialog) says the motors are running closed loop and I can jog from within the IDE and from NC16.

 

Do I need a script file to handle the G-Codes?

 

The guy before me setup coordinate system 1, not 0. And used motor 1 and 2 instead of 0 and 1. Does that matter? I'm kinda fishing for answers ...

Link to comment
Share on other sites

The first line should just switch to rapid move, but not move anything.

The second line should move X either to 0.1 or by 0.1. You might want to add G90 or G91 to be sure.

The third line is just end of program.

 

Are you sure X doesn't move?

 

What response do you get if you type the following into the IDE terminal?

#1->

 

The guy before me setup coordinate system 1, not 0. And used motor 1 and 2 instead of 0 and 1. Does that matter?

That's normal and expected.

Link to comment
Share on other sites

You need to load the supplied Project modified for your hardware. This contains the “script file to handle the G-Codes”. See the supplied documentation in the “Documents” folder for implementation details. Specifically:

PowerPmacNC Quick Start_Ver6.pdf

PowerPmacNC ini Configuraton Manual_Ver2.pdf

PowerPmacNC Software Users Manual_Ver7-121217.pdf

PowerPmacNC-Mill Manual_Ver3.pdf

Link to comment
Share on other sites

You need to load the supplied Project modified for your hardware. This contains the “script file to handle the G-Codes”. See the supplied documentation in the “Documents” folder for implementation details. Specifically:

PowerPmacNC Quick Start_Ver6.pdf

PowerPmacNC ini Configuraton Manual_Ver2.pdf

PowerPmacNC Software Users Manual_Ver7-121217.pdf

PowerPmacNC-Mill Manual_Ver3.pdf

 

I do not see anything about G-Code script files that is not specific to the NC16 projects built from source. We are using the default project as recommended by DT. The equivalent instructions are not clear (or present). I'm a cross platform real-time software developer and with respect, the documentation is pretty obtuse.

 

Edit: Found the gcode script was there but not active. Removed all the Y axis references (since it is a fancy lathe) and it is working

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...