Jump to content
OMRON Forums

about massage "unable to initialize binary rotary buffer"


Iman
 Share

Recommended Posts

hi, everyone,

I have a 220 UPL Machine and Made by Nanotech Company.

THIS MACHINE HAS A TURBO PMAC 2.

WHEN I TURN ON THIS MACHINE THE GREEN LED OF PMAC IS ON.

AND AFTER I USED MotionExe software, (after setup) this software indicate this massage ->" the pmac device was successfully loaded".( I attached picture)

but when I want to open NCUI32(PMACNC-32), I encountered this massage->" unable to initialize binary rotary buffer"

and after press ok another massage indicate:->"Abnormal program termination"

Does anyone know what these messages are and how to fixed it?

best regard

54.PNG

55.PNG

15.jpg

14.jpg

10.jpg

9.jpg

1.jpg

Link to comment
Share on other sites

This software has been obsolete for over 15 years and is no longer supported.

Have you contacted the machine builder? If they cannot provide support, we may be able to find a third party integrator that “knows” this software.

Form your description it sounds as if the DP RAM option has been compromised and will require repair.

 

Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)

Hi,

Thanks for response,

I used this DPRAM for the first time.

I think,This error is due to the lack of software TurboSetup.exe.

because when i want to open Ncsetup, this massage indicate. "Can Not Find TurboSetup.exe PI. Install it!!!"

also in pdf in the section of "Running the cnc autopilot program" explain this subject about TurboSetup.

also when the NCsetup is open, when i press pmac setup the pewin is open and indicate this massage.

thanks for attention

 

 

 

20220307_110542.jpg

20220307_150907.jpg

IMG-20220307-WA0007.jpg

IMG-20220307-WA0008.jpg

Edited by Iman
Link to comment
Share on other sites

  • 1 month later...
On 2/22/2022 at 12:37 PM, Iman said:

hi, everyone,

I have a 220 UPL Machine and Made by Nanotech Company.

THIS MACHINE HAS A TURBO PMAC 2.

WHEN I TURN ON THIS MACHINE THE GREEN LED OF PMAC IS ON.

AND AFTER I USED MotionExe software, (after setup) this software indicate this massage ->" the pmac device was successfully loaded".( I attached picture)

but when I want to open NCUI32(PMACNC-32), I encountered this massage->" unable to initialize binary rotary buffer"

and after press ok another massage indicate:->"Abnormal program termination"

Does anyone know what these messages are and how to fixed it?

best regard

54.PNG

55.PNG

15.jpg

14.jpg

10.jpg

9.jpg

1.jpg

Which OS are you using ?

Link to comment
Share on other sites

Don’t use the “Setup” button. Instead, setup motors manually if you do not have a full configuration.

If you already have motor configuration code, note that the Turbo Setup program does not setup DPRAM. This needs to be done as outlined in the NC32 documentation.

Please contact ODT's direct technical support to troubleshoot your issue at:

ODT-Support@omron.com

 

Link to comment
Share on other sites

  • 2 months later...

I don't like seeing two PMAC devices 0 and 1 when there is only one PMAC in the system. Delete the second one. Also, please provide a list of I1..I99 as this is where the communications configuration is setup.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...