Jump to content
OMRON Forums

MySql Fails to Start - Install IDE shows MYSQL Install Fail - RESOLVED - IDE3 UPDATE


Unit101
 Share

Recommended Posts

Problem:

New install of IDE (v2.2.0.39) on new PC with fresh Win 10 Pro x64 OS.

At end of install it says Database failed and prompts you to run the IDE troubleshooter.

Message Dialog like this: "Power PMAC IDE Installation Varification Report"

MySQL databases are no created.

NOTE: Please go to "IDE Troubleshooting"....

In IDE Troubleshooter you run button "IDE Troubleshooting" it says database repaired.

However it is NOT.

When you run IDE in Output window after starting you get a message like this:

Database Error: Unable to connect to any of the specified MySQL hosts...

 

What is Wrong:

MySQL service is NOT starting and running.

Go to Computer Services - Select MySQL in list - select Start.

It will fail with a Error 1067.

Open \data\compName.err and you see this :

InnoDB: Operating system error number 87 in a file operation.

File name .\ib_logfile0

File operation call: 'aio read'.

 

When MySQL starts it can't write to the ib_logfile0

- this seems to be a issue with how large the drive is and it sectors being 4096 instead of 512 in size

- so if you are running on a large >1.5TB or so this is a problem

 

FIX:

- only temporary fix ... if you manually DELETE the \data\ib_logfile0 then you can

start the MySQL no problem

- now start IDE and it is working with it's DBASE files fine

 

HOWEVER:

- next time you start system MySQL will FAIL to Start Again

 

Permanent fix:

- widely reported that a new switch is available in 5.6 > that lets you allow for

this, adding a line to my.ini will fix this issue

- but it appears we are using a older version for MySQL 5.0 so it is not supported

 

Can we simply manually install a newer MySQL and have the IDE use this ? I

don't see why not as long as the service is started and pointing to the correct dbase files... I will give this a try.

 

Thanks for any other suggestions or help.

 

mike

Link to comment
Share on other sites

  • Replies 9
  • Created
  • Last Reply

Top Posters In This Topic

Continue to work on this issue.

 

To make it work fine all I need to do is delete file:

C:\Program Files (x86)\MySQL\MySQL Server 5.0\data\ib_logfile0

 

Then start the MySQL service.

It starts fine and IDE seems happy with the database, Intellisense works...

 

Tried putting the MySQL in a different directory, no joy.

 

Also seems to ignore the my.ini settings related to database location, if

I change this and move the data dir it still works in same local dir as always.

In fact you can modify any of the my.ini settings and seems to have no effect when starting the service or process.

 

The fix is supposed to be add this line to my.ini

innodb_flush_method=normal

 

But I don't believe the ini is having any effect on startup... it is simply using some defaults.

 

Again if interested here is error log on startup of MySQL:

161226 6:51:18 InnoDB: Operating system error number 87 in a file operation.

InnoDB: Some operating system error numbers are described at

InnoDB: http://dev.mysql.com/doc/refman/5.0/en/operating-system-error-codes.html

InnoDB: File name .\ib_logfile0

InnoDB: File operation call: 'aio read'.

InnoDB: Cannot continue operation.

 

Here is same LOG if I Delete the ib_logfile0 FIRST, it starts up fine

161226 6:54:12 InnoDB: Log file .\ib_logfile0 did not exist: new to be created

InnoDB: Setting log file .\ib_logfile0 size to 5 MB

InnoDB: Database physically writes the file full: wait...

InnoDB: Error: all log files must be created at the same time.

InnoDB: All log files must be created also in database creation.

InnoDB: If you want bigger or smaller log files, shut down the

InnoDB: database and make sure there were no errors in shutdown.

InnoDB: Then delete the existing log files. Edit the .cnf file

InnoDB: and start the database again.

161226 6:54:12 [Note] C:\Program Files (x86)\MySQL\MySQL Server 5.0\bin\mysqld-nt.exe: ready for connections.

Version: '5.0.41-community-nt' socket: '' port: 3306 MySQL Community Edition (GPL)

 

I'm convinced the issue is that I'm using a 2TB SSD and that MySQL is NOT using the my.ini settings... it reads it... but ignores the settings

 

Thanks

Link to comment
Share on other sites

RESOLVED !!!

 

Ok I was on the right track.

 

#1 forget about the my.ini it is not being used, not sure why but it is ignored by the MySQL service startup configured by IDE

- you can delete this file and it runs exactly the same

- the MySQL ignores ANY Settings in this file, including the location of Dbase files

- perhaps it is read by the IDE ?

 

#2 Issue is related to the size and type of HDD that IDE is installed on

Link to comment
Share on other sites

RESOLVED !!!

 

Ok I was on the right track.

 

#1 forget about the my.ini it is not being used, not sure why but it is ignored by the MySQL service startup configured by IDE

- you can delete this file and it runs exactly the same

- the MySQL ignores ANY Settings in this file, including the location of Dbase files

- perhaps it is read by the IDE ?

 

#2 Issue is related to the size and type of HDD that IDE is installed on

- some GBP or SSD, RAID ... larger drives >1.5TB will show this issue

- it is related to sector size of formatted drive

 

#3 FIX is well documented by other MySQL users

- it is to tell MySQL to use this when writing the files (logs)

innodb_flush_method=normal

 

- most users simply put this i the my.ini (or cnf linux) and it is fixed

- but as #2 states the my.ini is here ignored

 

#4 How to FIX

- go to regedt32 - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MySQL

- edit the Image Path (startup cmd)

- add cmd line switch to tell MySQL to use above "flush method"

- here is what it should look like:

"C:\Program Files (x86)\MySQL\MySQL Server 5.0\bin\mysqld-nt.exe" "--innodb_flush_method=normal --defaults-file=C:\Program Files (x86)\MySQL\MySQL Server 5.0\my.ini" MySQL

 

- notice I added the --innodb_flush_method=normal cmd line switch

- now this feature is used on startup and it works fine

 

I suspect this will NOT impact other systems... so would like to test on a typical system to see if still works fine... but I'm not a SQL expert... just weathered a bit.

Link to comment
Share on other sites

  • 7 months later...

I had SAME ISSUE with IDE 3.0.1.0 INSTALL.

It fails to install and start the MySql service, it tells me to uninstall MySql which does not fix issue.

 

Error during install is with a Dialog box message:

"Failed to start the 'MySQL' service. Please try uninstalling 'MySQL'... and rerun the

PowerPMAC IDE installer."

 

Fix is same as before but now implemented using ini file, it appears that IDE3 is NOW using the MySql ini file on startup, the IDE2 did not.

 

1. So go to C:\Program Files (x86)\MySQL\MySQL Server 5.0

2. Edit the file "ppmac.ini"

Attached is my ppmac.ini file (rename from .txt to .ini to use this)

3. Add this line to the file inside the # SERVER SECTION

innodb_flush_method=normal

4. Save file

5. Rerun the IDE install (do NOT uninstall MySql)

6. Now the MySql will start and IDE will complete install and run ok.

ppmac.txt

Link to comment
Share on other sites

  • 2 months later...
  • 10 months later...

UPDATE 11/8/17 NEW INSTALL with Version 3.1.1.0 has same Issue.

 

It will fail to install with same error, MySql won't Start.

Need to do same fix to ppmac.ini file as before and re-install.

 

Hello Mike,

 

Hi have a similar issue on IDE v.4: I'm trying to update my IDE from 4.0.3.0 to 4.1.0.24 using the patch installation. At the very beginning of the installation (as administrator), I have an MYSQL failure message:

 

"Failed to install the 'MySQL' tables required for PowerPMAC IDE (error code: failed to get port). Please try rebooting the PC and running the installer again."

 

I updated the .ini file but it did not work, the problem might be a different one.

Have you encountered this ? Do you have any fix ?

 

Thanks !

 

EDIT: solved by uninstalling everything and installing directly the full 4.1.0.24 firmware.

Link to comment
Share on other sites

  • 2 months later...

UPDATE 11/8/17 NEW INSTALL with Version 3.1.1.0 has same Issue.

 

It will fail to install with same error, MySql won't Start.

Need to do same fix to ppmac.ini file as before and re-install.

 

We have a similar issue with 4.2.0.13 fresh install on a clean Windows 10 (256 GB SSD) build. MySQL fails to install tables (error 1).

 

Tried following the suggested fixes, however it appears to be failing at an earlier stage in the process and as such deletes the ppmac4.ini (as per log below), as part of the failed install cleanup.

 

"1: Custom Action: The 'Install_PPMAC_MySQL_Files' batch file failed (error code: 1)

1: Custom Action: Entering 'RemovePMACMySQLDataFiles' function

1: Custom Action: Deleted 'ppmac4.ini' from C:\Program Files (x86)\MySQL\MySQL Server 5.0

...

CustomAction Install_PMAC_MySQL_Files returned actual error code 1602"

 

Based on the nature of the issue, we thought the quickest way to resolve this might be to create a new partition on the SSD, with sector size that MySQL 5 tables will be happy with.

 

Any suggestions appreciated...

Capture.PNG.c7a25f2e129c49717fdeef4bc8813493.PNG

Link to comment
Share on other sites

  • 3 months later...
Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...