Jump to content
OMRON Forums

pp_proj.h not populated


kevin gilliland
 Share

Recommended Posts

PowerPMAC IDE 3.1.0.6

CK3E firmware 2.2.0.21

 

Am building a background cplc. I understand that the IDE populates the include file pp_proj.h. This has worked for me when I have been experimenting with _EnumMode_ and _PPScriptMode_.

 

Now, for some reason, the pp_proj.h file isn't being populated. Have done all level of resets, cleans, PC reboots, run as administrator and IDE re-installs but header is still empty resulting in undeclared variables.

 

Frustrating as it used to work and now doesn't but I don't know what changed.

 

Any suggestions?

Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

glad all working...

 

BUT... and a BIG BUTTTT

 

Having the IDE so tied to only working with new firmware is a huge issue if true !!!

 

OEM's ship dozens a month with firmware as received... and tech's, field engineers all have different versions of IDE... if one upgrades he is dead... customers as well...

 

IF a IDE version only works with Firmware x.x.x. then if needs to be very clear.

And if the IDE connects to a older firmware pmac it should show a big warning.

 

I've been in IDE hell for 3 days now dealing with getting once fine code to run on same PMAC's but with new IDE.

Link to comment
Share on other sites

I agree a better method of managing IDE and FW versions is needed.

 

We have 30 to 40 PMAC systems in our production facilities right now, all running various versions of FW and IDE.

 

While upgrading FW on some of our production equipment we've broken projects than ran fine for months or years on older FW, so our support folks are hesitant to upgrade FW on PMACs that are running fine. On the other hand, trying to support all those different FW versions can be a major pain.

Link to comment
Share on other sites

Another issue we've seen in the same realm - if we update either the firmware or IDE, we usually end up having to recreate the whole pmac project and re-import all of the script files. The new IDE generally seems to be okay talking to older firmware if I build a new project. But then if I switch computers, an old IDE has trouble loading that new project.
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...