Jump to content
OMRON Forums

List of All Tested EtherCAT Devices


Highland Controls
 Share

Recommended Posts

  • Replies 29
  • Created
  • Last Reply

Top Posters In This Topic

Delta Tau is a regular participant at the EtherCAT North America plugfest to help insure interoperability with various slave modules, both I/O and drives. In addition, many drives are kept at Delta Tau's facility from various manufactures for testing.

 

At the moment we have tested the following slave devices under Power PMAC EtherCAT master control:

 

Servo Drives:

 

ABB ACSM1-04AM-02A5-4 with FECA-01 EtherCAT module

ABB ACS800

Copley Accelnet Plus Drive

Copley Xenus Plus Drive

CT Digitax ST

CT Unidrive M

Danaher S70301-US Drive

Emerson DST1204 Drive

Kollmorgen AKD P00606-NAEC-0000

Lenze i700

LTI ServoOne

Omron R88D-KN02L-ECT Drive

Sanyo Denki - SanMotion RS2E01AOKA4

Servotronix CDHD

Technosoft IPOS4808 VX-CAT

Yaskawa SGDV Drive with SGDV-OCA01A EtherCAT module

 

IO modules:

 

ABB CI512-ETHCAT IO module

Beckhoff EK1100 EtherCAT coupler with added ELxxxx IO modules

Omron GX-xD16x1/OC1601 EtherCAT IO Module

Link to comment
Share on other sites

  • 1 year later...

Delta Tau is adding the following EtherCAT I/O device.

  • ACC-52EC, ECAT I/O Module is general purpose EtherCAT input/output (I/O) peripheral device.

 

 

IO modules (REVISED):

Delta Tau ACC-52EC, ECAT I/O Module

ABB CI512-ETHCAT IO module

Beckhoff EK1100 EtherCAT coupler with added ELxxxx IO modules

Omron GX-xD16x1/OC1601 EtherCAT IO Module

Link to comment
Share on other sites

Delta Tau is adding the following EtherCAT I/O device.

  • ACC-52EC, ECAT I/O Module is general purpose EtherCAT input/output (I/O) peripheral device.

 

 

IO modules (REVISED):

Delta Tau ACC-52EC, ECAT I/O Module

ABB CI512-ETHCAT IO module

Beckhoff EK1100 EtherCAT coupler with added ELxxxx IO modules

Omron GX-xD16x1/OC1601 EtherCAT IO Module

Link to comment
Share on other sites

  • 3 months later...

Updated List of EtherCAT Devices

 

Servo Drives:

ABB ACSM1-04AM-02A5-4 with FECA-01 EtherCAT module

ABB E180 and ABB ACS800 Drives

Copley Accelnet Plus AEP Drive

Copley Accelnet Plus BE2 Dual Axis Drive

Copley Xenus Plus XEL Drive

CT Emerson Digitax DST1204 Drive

CT Unidrive M, Drive

Danaher S70301-US, Drive

Delta ASDA-A2-E

Elmo DC Drive (CS Pos, CS Vel, CS Torq Modes)

HIWIN D2 1023-E-C4, w/Ecat Module, Drive

Kollmorgen AKD P00606-NAEC-0000, Drive

Kollmorgen AKD P00607-NBEC-0000, Drive

Lenze i700, Drive

LS Mecapion L7NA002B (E-Motion)

LTI ServoOne

Mitsubishi MR-J4-10TM & -40TM, Drives

Omron R88D-KN02L-ECT Drive

Omron R88D-KN01L-ECT Drive

Omron R88D-1SN01L-ECT Drive

Panasonic MBDHT2110B01, Drive

Panasonic MCDHT3520B01, Drive

Sanyo Denki - SanMotion RS2E01AOKA4, Drive

Servotronix CDHD, Drive

Technosoft IPOS4808 VX-CAT, Drive

Yaskawa SGDV Drive with SGDV-OCA01A EtherCAT module

Yaskawa SGDVII Drive

 

IO modules:

ABB CI512-ETHCAT, IO module

Beckhoff EK1100 EtherCAT coupler w/ EL1008, EL2008 IO Modules

Delta Tau ACC-52ECx 16/16, IO Module

Micro-Epsilon's ConfocalDT (see setup document in link found in Post #10 of this thread)

Omron GX-ID1621 EtherCAT, IO Module

Omron GX-OD1621 EtherCAT, IO Module

Link to comment
Share on other sites

  • 2 years later...

Yep it connects as an I/O device. Believe it or not I actually wrote an app note on that already. I think it's here:

 

http://forums.deltatau.com/filedepot/download.php?f=Power%20PMAC/Application%20Notes/EtherCAT/Using%20Micro-Epsilon%27s%20IFC2451%20with%20Power%20PMAC.pdf [FILE REMOVED]

Link to comment
Share on other sites

  • 3 months later...

Hi,

I am facing problems with Ethercat Between Delta Tau Power Clipper and Kollmorgen AKD-P00607-NBCC-E000 Drive.

Still in testing phase. The Actual motor position does not update continuously.

I have not enabled the drive. If I rotate the motor with my hand the position does not update.

But If I deactivate and activate the Ethercat the position gets updated. Am I missing anything or is it a bug.

Firmware Version is 2.2.0.39.

Link to comment
Share on other sites

Please contact our Tech Support department for further information. AKD drives typically require initialization of various EtherCAT objects. The setup depends upon which EtherCAT stack and mode that you are using.

 

EtherCAT Modes ($6060)

0 No mode change/no mode assigned

1 Profile position mode

2 Velocity mode

3 Profile velocity mode

4 Torque profile mode

5 reserved

6 Homing mode

7 Interpolated position mode

8 Cyclic sync position mode

9 Cyclic sync velocity mode

10 Cyclic sync torque mode

 

Delta Tau supports the Cyclic Synchronous modes e.g. (8, 9, 10), and homing mode (6). We have on occasion observed customers use Profile modes despite the fact that we do not support them.

 

You may need to contact AKD to see which modes the firmware version you are using supports. If forced to use a Profile mode then setting the profile boundaries to their maximum/most aggressive slopes will imitate the corresponding Cyclic Synchronous mode. That will need to be done within the AKD using the Kollmorgen setup software. You will need to contact Kollmorgen support for guidance on that subject.

 

If you are using the Etherlab Stack try the following, see attachment for info on the ecatsdo( ) and ecattypedsdo( ) commands.

// AKD EtherCAT Drive in position 0

// Add the following items to your ecatactivate0.cfg file:

l0 = ecatsdo(0,0,$1601,0,0,0)

l0 = ecatsdo(0,0,$1602,0,0,0)

l0 = ecatsdo(0,0,$1603,0,0,0)

l0 = ecatsdo(0,0,$1a01,0,0,0)

l0 = ecatsdo(0,0,$1a02,0,0,0)

l0 = ecatsdo(0,0,$1a03,0,0,0)

l0 = ecatsdo(0,0,$1c12,0,0,0)

l0 = ecatsdo(0,0,$1c13,0,0,0)

 

note: l0 = ecatsdo(0,0,$6060,0,8,0) and a couple more entries should already be in the ecatactivate0.cfg file.

ecatsdoCommand_R1_2.pdf

Link to comment
Share on other sites

  • 2 months later...

Hi,

I am facing problems with Ethercat Between Delta Tau Power Clipper and Kollmorgen AKD-P00607-NBCC-E000 Drive.

Still in testing phase. The Actual motor position does not update continuously.

I have not enabled the drive. If I rotate the motor with my hand the position does not update.

But If I deactivate and activate the Ethercat the position gets updated. Am I missing anything or is it a bug.

Firmware Version is 2.2.0.39.

 

Same here, along with various bus crashes, dropped frames and overall PMAC Clipper non-responsive.

Firmware 2.1.0.39 (unable to update Power PMAC Clipper past that version due to boot-up crash).

Etherlab stack.

CPU command returns PowerPC,APM86xxx

Sys.CPUType = 4

Serial C0C0DVG1

Part #4-4050JA0-330-010000

Variant Code 101F

 

Drive I am using is AKD-P00306-NBEC-0069 HW Rev. D with latest AKD Firmware 01-16-00-002 and ESI definition from http://www.kollmorgen.com/en-us/products/drives/servo/akd/_software-firmware/akd-servo-drive-firmware-and-ethercat-device-description-akd-p-nbec-01-16-00-002/

 

I have been able to get live position updates but still unable to command motor moves under either default startup config from XML (Interpolation Position Mode) nor Cyclic Position or Cyclic Torque modes.

Link to comment
Share on other sites

  • 3 months later...

someone is it working with NX Modules (Omron)?

 

the Ethercat configuration into the "System Setup" only load the Ethercat Coupler file (NX-ECC20x) but when i try to load the modules files nothing happend.

 

I tried load the ESI file into the "ESI MANAGER" of "EC-Engenier" and when i load the NX-Modules.XML file the system says that the file is invalid.

 

My Ethercat Configuration is:

 

NX-ECC203 (Version 1.5) / DA2605 / EC0132 / EC0132 / ID5442 / OD5121

Link to comment
Share on other sites

I have had the most success by including all relevant ESI files (for all modules and also for the coupler) in a single folder, then either adding that full folder through the ESI manager or selecting the coupler (with all other devices in the same location).

 

When doing that, I've always been able to successfully append the modules onto the coupler (or scan the network and detect them properly).

1346936443_CouplerwithModules.thumb.PNG.4e2d2e924a25e08b238bb91cda27675e.PNG

Link to comment
Share on other sites

  • 1 month later...

someone is it working with NX Modules (Omron)?

 

the Ethercat configuration into the "System Setup" only load the Ethercat Coupler file (NX-ECC20x) but when i try to load the modules files nothing happend.

 

I tried load the ESI file into the "ESI MANAGER" of "EC-Engenier" and when i load the NX-Modules.XML file the system says that the file is invalid.

 

My Ethercat Configuration is:

 

NX-ECC203 (Version 1.5) / DA2605 / EC0132 / EC0132 / ID5442 / OD5121

Assuming that you are using a PowerPMAC with the Acontis ethercat stack (CK3Eor NY512) you should see the NX coupler and the modules when you scan your network. If you do not check to be sure that you have loaded the correct Omron NX_Modules.xml file into EC Engineer. If you have Sysmac Studio loaded it will be found at:

 

C:\Program Files (x86)\OMRON\Sysmac Studio\IODeviceProfiles\EsiFiles\SystemEsiFiles

 

Make sure that your Sysmac Studio is up to date.

Link to comment
Share on other sites

  • 5 months later...

I have had success with the following devices on the CK3E Acontis Stack:

 

AKD-P02407-NBCC (running in Torque Mode, also mapped the servo drive brake control over the network)

AKD-C01007-CBEC (power distribution module for AKD distributed drives)

AKD-N00307-DFEC (AKD Distributed drive, Torque Mode)

AKD-N00607-DFEC (AKD Distributed drive, Torque Mode)

AKD-N01207-DFEC (AKD Distributed drive, Torque Mode)

 

Kistler Type 5074A - 4 channel industrial charge amplifier, limited to 1khz bus frequency.

Link to comment
Share on other sites

I have had success with the following devices on the CK3E Acontis Stack:

 

AKD-P02407-NBCC (running in Torque Mode, also mapped the servo drive brake control over the network)

AKD-C01007-CBEC (power distribution module for AKD distributed drives)

AKD-N00307-DFEC (AKD Distributed drive, Torque Mode)

AKD-N00607-DFEC (AKD Distributed drive, Torque Mode)

AKD-N01207-DFEC (AKD Distributed drive, Torque Mode)

 

Kistler Type 5074A - 4 channel industrial charge amplifier, limited to 1khz bus frequency.

 

Thank-you for the input.

Link to comment
Share on other sites

  • 1 year later...
Has there been success or testing with the KEB Automation drive products? Fought with there F6K drive, sent back for testing(nothing wrong), and OEM gave up on product. The F6K would power-up ok and the ECat LED's would come to life like normal until CK3E would attempt to enable ECat then drive ECat LED would go red and the slave could be seen during an "ecat reset" but never goes to PreOp state. The CK3E error is $98110024. One note about the KEB drives: They don't have the ability to set address through hardware, it bases its address on where its plugged in the chain.
Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...